summaryrefslogtreecommitdiff
path: root/recipes/openssh/openssh-4.0p1
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openssh/openssh-4.0p1
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openssh/openssh-4.0p1')
-rw-r--r--recipes/openssh/openssh-4.0p1/configure.patch233
-rw-r--r--recipes/openssh/openssh-4.0p1/ssh_config38
-rw-r--r--recipes/openssh/openssh-4.0p1/sshd_config96
3 files changed, 367 insertions, 0 deletions
diff --git a/recipes/openssh/openssh-4.0p1/configure.patch b/recipes/openssh/openssh-4.0p1/configure.patch
new file mode 100644
index 0000000000..ddfe21d164
--- /dev/null
+++ b/recipes/openssh/openssh-4.0p1/configure.patch
@@ -0,0 +1,233 @@
+Index: openssh-4.0p1/configure.ac
+===================================================================
+--- openssh-4.0p1.orig/configure.ac 2005-03-07 04:21:37.000000000 -0500
++++ openssh-4.0p1/configure.ac 2005-03-12 23:43:25.057482040 -0500
+@@ -718,23 +718,21 @@
+ ]
+ )
+
+-AC_MSG_CHECKING([whether struct dirent allocates space for d_name])
+-AC_RUN_IFELSE(
+- [AC_LANG_SOURCE([[
+-#include <sys/types.h>
+-#include <dirent.h>
+-int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));}
+- ]])],
+- [AC_MSG_RESULT(yes)],
+- [
+- AC_MSG_RESULT(no)
+- AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
+- ],
+- [
+- AC_MSG_WARN([cross compiling: assuming BROKEN_ONE_BYTE_DIRENT_D_NAME])
+- AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
+- ]
+-)
++AC_CACHE_CHECK([whether struct dirent allocates space for d_name], ac_cv_have_space_d_name_in_struct_dirent, [
++ AC_RUN_IFELSE(
++ [AC_LANG_SOURCE([[
++ #include <sys/types.h>
++ #include <dirent.h>
++ int main(void){struct dirent d;exit(sizeof(d.d_name)<=sizeof(char));}
++ ]])],
++ [ ac_cv_have_space_d_name_in_struct_dirent="yes" ],
++ [ ac_cv_have_space_d_name_in_struct_dirent="no" ],
++ )
++])
++
++if test "x$ac_cv_dirent_have_space_d_name" = "xyes" ; then
++ AC_DEFINE(BROKEN_ONE_BYTE_DIRENT_D_NAME)
++fi
+
+ AC_MSG_CHECKING([for /proc/pid/fd directory])
+ if test -d "/proc/$$/fd" ; then
+@@ -987,20 +985,25 @@
+
+ # Check for broken snprintf
+ if test "x$ac_cv_func_snprintf" = "xyes" ; then
+- AC_MSG_CHECKING([whether snprintf correctly terminates long strings])
+- AC_RUN_IFELSE(
+- [AC_LANG_SOURCE([[
+-#include <stdio.h>
+-int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
+- ]])],
+- [AC_MSG_RESULT(yes)],
+- [
+- AC_MSG_RESULT(no)
+- AC_DEFINE(BROKEN_SNPRINTF)
+- AC_MSG_WARN([****** Your snprintf() function is broken, complain to your vendor])
+- ],
+- [ AC_MSG_WARN([cross compiling: Assuming working snprintf()]) ]
+- )
++ AC_CACHE_CHECK([whether snprintf correctly terminates long strings],
++ ac_cv_have_broken_snprintf, [
++ AC_RUN_IFELSE(
++ [AC_LANG_SOURCE([[
++ #include <stdio.h>
++ int main(void){char b[5];snprintf(b,5,"123456789");exit(b[4]!='\0');}
++ ]])],
++ [ac_cv_have_broken_snprintf="no"],
++ [ac_cv_have_broken_snprintf="yes"],
++ [
++ AC_MSG_WARN([cross compiling: Assuming working snprintf()])
++ ac_cv_have_broken_snprintf="yes"
++ ]
++ )
++ ])
++ if test "x$ac_cv_have_broken_snprintf" = "xyes" ; then
++ AC_DEFINE(BROKEN_SNPRINTF)
++ AC_MSG_WARN([****** Your snprintf() function is broken, complain to your vendor])
++ fi
+ fi
+
+ # Check for missing getpeereid (or equiv) support
+@@ -1045,49 +1048,49 @@
+
+ dnl make sure that openpty does not reacquire controlling terminal
+ if test ! -z "$check_for_openpty_ctty_bug"; then
+- AC_MSG_CHECKING(if openpty correctly handles controlling tty)
+- AC_TRY_RUN(
+- [
+-#include <stdio.h>
+-#include <sys/fcntl.h>
+-#include <sys/types.h>
+-#include <sys/wait.h>
+-
+-int
+-main()
+-{
+- pid_t pid;
+- int fd, ptyfd, ttyfd, status;
+-
+- pid = fork();
+- if (pid < 0) { /* failed */
+- exit(1);
+- } else if (pid > 0) { /* parent */
+- waitpid(pid, &status, 0);
+- if (WIFEXITED(status))
+- exit(WEXITSTATUS(status));
+- else
+- exit(2);
+- } else { /* child */
+- close(0); close(1); close(2);
+- setsid();
+- openpty(&ptyfd, &ttyfd, NULL, NULL, NULL);
+- fd = open("/dev/tty", O_RDWR | O_NOCTTY);
+- if (fd >= 0)
+- exit(3); /* Acquired ctty: broken */
+- else
+- exit(0); /* Did not acquire ctty: OK */
++ AC_CACHE_CHECK([if openpty acquires controlling terminal],
++ ac_cv_have_openpty_ctty_bug, [
++ AC_TRY_RUN(
++ [
++ #include <stdio.h>
++ #include <sys/fcntl.h>
++ #include <sys/types.h>
++ #include <sys/wait.h>
++
++ int
++ main()
++ {
++ pid_t pid;
++ int fd, ptyfd, ttyfd, status;
++
++ pid = fork();
++ if (pid < 0) { /* failed */
++ exit(1);
++ } else if (pid > 0) { /* parent */
++ waitpid(pid, &status, 0);
++ if (WIFEXITED(status))
++ exit(WEXITSTATUS(status));
++ else
++ exit(2);
++ } else { /* child */
++ close(0); close(1); close(2);
++ setsid();
++ openpty(&ptyfd, &ttyfd, NULL, NULL, NULL);
++ fd = open("/dev/tty", O_RDWR | O_NOCTTY);
++ if (fd >= 0)
++ exit(3); /* Acquired ctty: broken */
++ else
++ exit(0); /* Did not acquire ctty: OK */
++ }
+ }
+-}
+- ],
+- [
+- AC_MSG_RESULT(yes)
+- ],
+- [
+- AC_MSG_RESULT(no)
+- AC_DEFINE(SSHD_ACQUIRES_CTTY)
+- ]
+- )
++ ],
++ [ ac_cv_have_openpty_ctty_bug="no" ],
++ [ ac_cv_have_openpty_ctty_bug="yes"]
++ )
++ ])
++ if test "x$ac_cv_have_openpty_ctty_bug" = "xyes" ; then
++ AC_DEFINE(SSHD_ACQUIRES_CTTY)
++ fi
+ fi
+
+ if test "x$ac_cv_func_getaddrinfo" = "xyes" -a "x$check_for_hpux_broken_getaddrinfo" = "x1"; then
+@@ -2039,8 +2042,12 @@
+ exit 1;
+ else
+ dnl test snprintf (broken on SCO w/gcc)
+- AC_RUN_IFELSE(
+- [AC_LANG_SOURCE([[
++ # No need to check for a broken snprintf if we already know it's broken.
++ if test "x$ac_cv_func_snprintf" = "xyes" && test "x$ac_cv_have_broken_snprintf" != "xyes"; then
++ AC_CACHE_CHECK([whether snprintf correctly terminates long strings],
++ ac_cv_have_broken_snprintf, [
++ AC_RUN_IFELSE(
++ [AC_LANG_SOURCE([[
+ #include <stdio.h>
+ #include <string.h>
+ #ifdef HAVE_SNPRINTF
+@@ -2063,9 +2070,20 @@
+ #else
+ main() { exit(0); }
+ #endif
+- ]])], [ true ], [ AC_DEFINE(BROKEN_SNPRINTF) ],
+- AC_MSG_WARN([cross compiling: Assuming working snprintf()])
+- )
++ ]])],
++ [ac_cv_have_broken_snprintf="no"],
++ [ac_cv_have_broken_snprintf="yes"],
++ [
++ AC_MSG_WARN([cross compiling: Assuming working snprintf()])
++ ac_cv_have_broken_snprintf="yes"
++ ]
++ )
++ ])
++ if test "x$ac_cv_have_broken_snprintf" = "xyes" ; then
++ AC_DEFINE(BROKEN_SNPRINTF)
++ AC_MSG_WARN([****** Your snprintf() function is broken, complain to your vendor])
++ fi
++ fi
+ fi
+
+ dnl Checks for structure members
+@@ -2666,12 +2684,15 @@
+ )
+
+ if test "x$etc_default_login" != "xno"; then
+- AC_CHECK_FILE("/etc/default/login",
+- [ external_path_file=/etc/default/login ])
+ if test ! -z "$cross_compiling" && test "x$cross_compiling" = "xyes";
+ then
+ AC_MSG_WARN([cross compiling: Disabling /etc/default/login test])
+- elif test "x$external_path_file" = "x/etc/default/login"; then
++ external_path_file=/etc/default/login
++ else
++ AC_CHECK_FILE("/etc/default/login",
++ [ external_path_file=/etc/default/login ])
++ fi
++ if test "x$external_path_file" = "x/etc/default/login"; then
+ AC_DEFINE(HAVE_ETC_DEFAULT_LOGIN)
+ fi
+ fi
diff --git a/recipes/openssh/openssh-4.0p1/ssh_config b/recipes/openssh/openssh-4.0p1/ssh_config
new file mode 100644
index 0000000000..25ca7f56bd
--- /dev/null
+++ b/recipes/openssh/openssh-4.0p1/ssh_config
@@ -0,0 +1,38 @@
+# $OpenBSD: ssh_config,v 1.16 2002/07/03 14:21:05 markus Exp $
+
+# This is the ssh client system-wide configuration file. See
+# ssh_config(5) for more information. This file provides defaults for
+# users, and the values can be changed in per-user configuration files
+# or on the command line.
+
+# Configuration data is parsed as follows:
+# 1. command line options
+# 2. user-specific file
+# 3. system-wide file
+# Any configuration value is only changed the first time it is set.
+# Thus, host-specific definitions should be at the beginning of the
+# configuration file, and defaults at the end.
+
+# Site-wide defaults for various options
+
+# Host *
+# ForwardAgent no
+# ForwardX11 no
+# RhostsAuthentication no
+# RhostsRSAAuthentication no
+# RSAAuthentication yes
+# PasswordAuthentication yes
+# HostbasedAuthentication no
+# BatchMode no
+# CheckHostIP yes
+# StrictHostKeyChecking ask
+# IdentityFile ~/.ssh/identity
+# IdentityFile ~/.ssh/id_rsa
+# IdentityFile ~/.ssh/id_dsa
+# Port 22
+# Protocol 2,1
+# Cipher 3des
+# Ciphers aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour,aes192-cbc,aes256-cbc
+# EscapeChar ~
+Host *
+ ForwardX11 yes
diff --git a/recipes/openssh/openssh-4.0p1/sshd_config b/recipes/openssh/openssh-4.0p1/sshd_config
new file mode 100644
index 0000000000..8c1069d9a6
--- /dev/null
+++ b/recipes/openssh/openssh-4.0p1/sshd_config
@@ -0,0 +1,96 @@
+# $OpenBSD: sshd_config,v 1.59 2002/09/25 11:17:16 markus Exp $
+
+# This is the sshd server system-wide configuration file. See
+# sshd_config(5) for more information.
+
+# This sshd was compiled with PATH=/usr/bin:/bin:/usr/sbin:/sbin
+
+# The strategy used for options in the default sshd_config shipped with
+# OpenSSH is to specify options with their default value where
+# possible, but leave them commented. Uncommented options change a
+# default value.
+
+#Port 22
+Protocol 2
+#ListenAddress 0.0.0.0
+#ListenAddress ::
+
+# HostKey for protocol version 1
+#HostKey /etc/ssh/ssh_host_key
+# HostKeys for protocol version 2
+#HostKey /etc/ssh/ssh_host_rsa_key
+#HostKey /etc/ssh/ssh_host_dsa_key
+
+# Lifetime and size of ephemeral version 1 server key
+#KeyRegenerationInterval 3600
+#ServerKeyBits 768
+
+# Logging
+#obsoletes QuietMode and FascistLogging
+#SyslogFacility AUTH
+#LogLevel INFO
+
+# Authentication:
+
+#LoginGraceTime 120
+#PermitRootLogin yes
+#StrictModes yes
+
+#RSAAuthentication yes
+#PubkeyAuthentication yes
+#AuthorizedKeysFile .ssh/authorized_keys
+
+# rhosts authentication should not be used
+#RhostsAuthentication no
+# Don't read the user's ~/.rhosts and ~/.shosts files
+#IgnoreRhosts yes
+# For this to work you will also need host keys in /etc/ssh/ssh_known_hosts
+#RhostsRSAAuthentication no
+# similar for protocol version 2
+#HostbasedAuthentication no
+# Change to yes if you don't trust ~/.ssh/known_hosts for
+# RhostsRSAAuthentication and HostbasedAuthentication
+#IgnoreUserKnownHosts no
+
+# To disable tunneled clear text passwords, change to no here!
+#PasswordAuthentication yes
+#PermitEmptyPasswords no
+
+# Change to no to disable s/key passwords
+#ChallengeResponseAuthentication yes
+
+# Kerberos options
+#KerberosAuthentication no
+#KerberosOrLocalPasswd yes
+#KerberosTicketCleanup yes
+
+#AFSTokenPassing no
+
+# Kerberos TGT Passing only works with the AFS kaserver
+#KerberosTgtPassing no
+
+# Set this to 'yes' to enable PAM keyboard-interactive authentication
+# Warning: enabling this may bypass the setting of 'PasswordAuthentication'
+#PAMAuthenticationViaKbdInt no
+
+#X11Forwarding no
+#X11DisplayOffset 10
+#X11UseLocalhost yes
+#PrintMotd yes
+#PrintLastLog yes
+#KeepAlive yes
+#UseLogin no
+UsePrivilegeSeparation yes
+#PermitUserEnvironment no
+Compression no
+
+#MaxStartups 10
+# no default banner path
+#Banner /some/path
+#VerifyReverseMapping no
+
+ClientAliveInterval 15
+ClientAliveCountMax 4
+
+# override default of no subsystems
+Subsystem sftp /usr/libexec/sftp-server