summaryrefslogtreecommitdiff
path: root/recipes/openmoko-tools/openmoko-set-root-password.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/openmoko-tools/openmoko-set-root-password.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/openmoko-tools/openmoko-set-root-password.bb')
-rw-r--r--recipes/openmoko-tools/openmoko-set-root-password.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/openmoko-tools/openmoko-set-root-password.bb b/recipes/openmoko-tools/openmoko-set-root-password.bb
new file mode 100644
index 0000000000..55ed090da2
--- /dev/null
+++ b/recipes/openmoko-tools/openmoko-set-root-password.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "Set a root password for your Neo."
+SUMMARY = "On installation you will be prompted to set a root password. With \
+this password you can then log into the machine."
+LICENSE = "GPL"
+DEPENDS = "gtk+"
+
+SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=root-password;proto=http"
+S = "${WORKDIR}/root-password"
+PV = "1.0+svnr${SRCREV}"
+PE = "1"
+PR = "r1"
+
+do_compile () {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${sbindir}
+ install -m 0755 ${S}/root-password ${D}/${sbindir}/${PN}
+}
+
+pkg_postinst_${PN} () {
+ # assume we use display 0
+ DISPLAY=:0 ${sbindir}/${PN}
+}