summaryrefslogtreecommitdiff
path: root/recipes/nunome/nunome_1.0.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nunome/nunome_1.0.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nunome/nunome_1.0.2.bb')
-rw-r--r--recipes/nunome/nunome_1.0.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes/nunome/nunome_1.0.2.bb b/recipes/nunome/nunome_1.0.2.bb
new file mode 100644
index 0000000000..bf297b0699
--- /dev/null
+++ b/recipes/nunome/nunome_1.0.2.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Japanese input method plugin"
+HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "virtual/japanese-font"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/nunome-${PV}.tar.bz2 \
+ file://timer.patch;patch=1 \
+ file://nunome.patch;patch=1"
+S = "${WORKDIR}/nunome"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/Nnmlib INCLUDEPATH+=${S}/ui LIBS+=-L${S}"
+OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ sed -i -e 's,/opt/QtPalmtop/bin/,${bindir}/,g' "${S}/ui/nunome.h"
+ sed -i -e 's,/opt/QtPalmtop/,${palmtopdir}/,g' "${S}/ui/nunome.h"
+ printf "TEMPLATE=subdirs\nSUBDIRS=Nnmlib server ui dicman ui\n" >nunome.pro
+ cd Nnmlib && qmake -project -t lib && cd ../
+ cd server && qmake -project && printf "LIBS+=-lNnmlib\nTARGET=server.bin\n" >> server.pro && cd ../
+ cd dicman && qmake -project && printf "LIBS+=-lnunome -lNnmlib\nTARGET=dicman.bin\n" >> dicman.pro && cd ../
+ cd ui && qmake -project -t lib && printf "LIBS+=-lNnmlib\nTARGET=nunome\n" >> ui.pro && cd ../
+ find . -name "moc*"|xargs rm -f
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/lib
+ install -d ${D}${bindir}
+ install -d ${D}${palmtopdir}/i18n/ja
+ install -d ${D}${palmtopdir}/share/nunome
+
+ oe_libinstall -so libNnmlib ${D}${palmtopdir}/lib
+ install -m 644 nunome_uni.dic ${D}${palmtopdir}/share/nunome
+ install -m 755 server.bin ${D}${bindir}/nnmsrv
+ install -m 755 dicman.bin ${D}${bindir}/nnmDicman
+ install -m 644 ui/nunome.qm ${D}${palmtopdir}/i18n/ja
+ install -m 644 dicman/nnmDicman.qm ${D}${palmtopdir}/i18n/ja
+}