summaryrefslogtreecommitdiff
path: root/recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb')
-rw-r--r--recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb b/recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
new file mode 100644
index 0000000000..0c9b49755e
--- /dev/null
+++ b/recipes/nonworking/gnuboy/qtopiagnuboy_1.0.3.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "GameBoy Emulator based on SDL, QtE based Palmtop Environments Edition"
+SECTION = "base"
+PRIORITY = "optional"
+DEPENDS = "libsdl-qpe"
+
+SRC_URI = "http://www.warmi.net/zaurus/files/gnuboy-${PV}-qtopia3.tar.gz \
+ file://qtopiagnuboyl-hwkeys.patch;patch=1 \
+ file://gcc3.patch;patch=1"
+S = "${WORKDIR}/gnuboy"
+
+FILES = ""
+FILES_${PN} = "${palmtopdir}/"
+
+inherit qmake_base
+
+qtopiadir = "${S}/gnuboy-${PV}-qtopia2"
+
+do_compile() {
+ cd ${qtopiadir}
+ oe_runmake -f Makefile.qtopia SYS_INCS="-DQWS -I${qtopiadir}/sys/nix" CXXFLAGS="${CXXFLAGS} -DQWS -fno-rtti -fno-exceptions" \
+ QTOPIA_LIBS="-L${STAGING_LIBDIR} -Wl,-rpath-link,${STAGING_LIBDIR} -lqpe -lqte" LD="${CC}"
+ cd ${S}/qtopiagnuboyl
+ ${QMAKE} -spec ${QMAKESPEC} -after ${EXTRA_QMAKEVARS_POST} qtopiagnuboyl.pro
+ oe_runmake CXXFLAGS="${CXXFLAGS} -DQWS -fno-rtti -fno-exceptions"
+}
+
+do_install() {
+ install -m 755 -d ${D}${palmtopdir}/
+ install -m 755 -D qpe/bin/qtopiagnuboy ${D}${palmtopdir}/bin/qtopiagnuboy
+ install -m 755 -D qpe/bin/qtopiagnuboyl ${D}${palmtopdir}/bin/qtopiagnuboyl
+ install -m 644 -D qpe/pics/Gnuboy.png ${D}${palmtopdir}/pics/Gnuboy.png
+ install -m 644 -D qpe/apps/Games/qtopiagnuboy.desktop ${D}${palmtopdir}/Games/qtopiagnuboy.desktop
+}