summaryrefslogtreecommitdiff
path: root/recipes/nonworking/bogl
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/nonworking/bogl
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/nonworking/bogl')
-rw-r--r--recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb20
-rw-r--r--recipes/nonworking/bogl/libbogl_0.1.9.bb24
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb b/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb
new file mode 100644
index 0000000000..94a1d4e00b
--- /dev/null
+++ b/recipes/nonworking/bogl/bogl-utils-native_0.1.9.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Utilities for Ben's Own Graphics Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gd-native"
+PR = "2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
+S = "${WORKDIR}/bogl"
+
+inherit native
+
+do_compile() {
+ oe_runmake bdftobogl pngtobogl
+ # giftobogl doesn't work because gd no longer comes with GIF support
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}/
+ install -m 0755 bdftobogl pngtobogl ${STAGING_BINDIR}/
+}
diff --git a/recipes/nonworking/bogl/libbogl_0.1.9.bb b/recipes/nonworking/bogl/libbogl_0.1.9.bb
new file mode 100644
index 0000000000..db18ee3160
--- /dev/null
+++ b/recipes/nonworking/bogl/libbogl_0.1.9.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Ben's Own Graphics Library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "bogl-utils-native"
+PR = "2"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/b/bogl/bogl_${PV}-${PR}.tar.gz"
+S = "${WORKDIR}/bogl"
+
+do_compile() {
+ ln -sf ${STAGING_BINDIR_NATIVE}/bdftobogl .
+ ln -sf ${STAGING_BINDIR_NATIVE}/pngtobogl .
+ oe_runmake libbogl.so.0.1 libbogl.a
+}
+
+do_stage() {
+ oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+ install bogl*.h ${STAGING_INCDIR}/
+}
+
+do_install() {
+ oe_soinstall libbogl.so.0.1 ${STAGING_LIBDIR}/
+}
+