summaryrefslogtreecommitdiff
path: root/recipes/netsurf/netsurf_2.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-31 12:01:05 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-31 12:01:05 +0200
commit6a8b960862f8ab048b42009d6c30d1d5561ad6bb (patch)
tree86ae2e2561bd29d1ce89646ac0512fd4839ef852 /recipes/netsurf/netsurf_2.1.bb
parentd6606b5feead01f3f6b4e51d0d4cddb601ac7992 (diff)
parentbbbd4a93365f40d6d43e13486172729ebfa3f9ad (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/netsurf/netsurf_2.1.bb')
-rw-r--r--recipes/netsurf/netsurf_2.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/netsurf/netsurf_2.1.bb b/recipes/netsurf/netsurf_2.1.bb
new file mode 100644
index 0000000000..073f17f53b
--- /dev/null
+++ b/recipes/netsurf/netsurf_2.1.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "Lightweight web browser capable of handling many of the \
+web standards in use today."
+HOMEPAGE = "http://www.netsurf-browser.org/"
+SECTION = "x11/network"
+LICENSE = "GPLv2"
+
+SRC_URI = "http://www.netsurf-browser.org/downloads/releases/netsurf-${PV}-src.tar.gz \
+ file://fix_makefile.patch;patch=1 \
+ file://debugxml_fix.patch;patch=1 \
+ file://netsurf.png \
+ file://netsurf.desktop \
+ file://Makefile.config"
+
+# Workaround for 2.1 tarball (unpacks into netsurf/, not netsurf-2.1/ )
+S = "${WORKDIR}/netsurf"
+
+DEPENDS = "gtk+ lemon-native re2c-native jpeg openssl curl libxml2 \
+ libglade hubbub libnsgif libnsbmp lcms"
+
+EXTRA_OEMAKE = "CURDIR=${S} DESTDIR=${D} PREFIX=${prefix}"
+
+do_configure() {
+ cp ${WORKDIR}/Makefile.config ${S}/
+}
+
+do_install() {
+ oe_runmake install
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -m 0644 ${WORKDIR}/netsurf.png ${D}/${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/netsurf.desktop ${D}/${datadir}/applications/
+}