summaryrefslogtreecommitdiff
path: root/recipes/mozilla/firefox_3.5.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-01 12:14:34 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-01 13:12:00 +0200
commit1fb6ea09d2c75b67627835aa3d055df5e168ca29 (patch)
tree434bf68c46b9b04e2fe529cd7b0a997153f1aa7c /recipes/mozilla/firefox_3.5.2.bb
parent96f8ec7a61658573adf438763f392bccc8c6f3c7 (diff)
firefox 3.5.2: sync with AlwaysInnovating overlay
Diffstat (limited to 'recipes/mozilla/firefox_3.5.2.bb')
-rw-r--r--recipes/mozilla/firefox_3.5.2.bb38
1 files changed, 35 insertions, 3 deletions
diff --git a/recipes/mozilla/firefox_3.5.2.bb b/recipes/mozilla/firefox_3.5.2.bb
index 4e5eb24dc3..75f29408b8 100644
--- a/recipes/mozilla/firefox_3.5.2.bb
+++ b/recipes/mozilla/firefox_3.5.2.bb
@@ -1,5 +1,5 @@
DEPENDS += "cairo"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}-source.tar.bz2 \
file://jsautocfg.h \
@@ -12,6 +12,9 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/
file://0001-Remove-Werror-from-build.patch;patch=1 \
file://0002-Fix-security-cross-compile-cpu-detection-error.patch;patch=1 \
file://plugins-dir.patch;patch=1 \
+ file://firefox-plugin.pc \
+ file://firefox-xpcom.pc \
+ file://nspr.pc \
"
S = "${WORKDIR}/mozilla-1.9.1"
@@ -19,6 +22,9 @@ S = "${WORKDIR}/mozilla-1.9.1"
inherit mozilla
require firefox.inc
+EXTRA_OECONF += " --enable-official-branding "
+
+
export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
FULL_OPTIMIZATION = "-fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2"
@@ -29,13 +35,39 @@ do_compile_prepend() {
do_stage() {
install -d ${STAGING_INCDIR}/firefox-${PV}
- cd dist/sdk/include
- rm -rf obsolete
+ cd ${S}/dist/sdk/include
+ cp -a obsolete ${STAGING_INCDIR}/firefox-${PV}/
+ rm -rf obsolete
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
+ done
+ cd ${S}/dist/include/plugin
+ headers=`find . -name "*.h"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
+ done
+ cd ${S}/nsprpub/pr/include
headers=`find . -name "*.h"`
for f in $headers
do
install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
done
+ cd ${S}/xpcom/base
+ headers=`find . -name "*.idl"`
+ for f in $headers
+ do
+ install -D -m 0644 $f ${STAGING_INCDIR}/firefox-${PV}/
+ done
+
+ install -d ${PKG_CONFIG_DIR}
+ install -m 0644 ${WORKDIR}/firefox-plugin.pc ${PKG_CONFIG_DIR}
+ install -m 0644 ${WORKDIR}/firefox-xpcom.pc ${PKG_CONFIG_DIR}
+ install -m 0644 ${WORKDIR}/nspr.pc ${PKG_CONFIG_DIR}
+ install -m 0755 ${S}/xpcom/typelib/xpidl/host_xpidl ${STAGING_BINDIR_NATIVE}/xpidl
+
# removes 2 lines that call absent headers
sed -e '178,179d' ${STAGING_INCDIR}/firefox-${PV}/nsIServiceManager.h
}