summaryrefslogtreecommitdiff
path: root/recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-08-18 14:52:06 +0100
committerGraeme Gregory <dp@xora.org.uk>2009-08-18 14:52:06 +0100
commit3942e499aea0ea4b64ca53fdc06a9495bf4fd503 (patch)
tree782893c3e64229ef1f49536ce2102638947d4b29 /recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch
parent3de2a694e2cdd17bf741c7b70a72ed7026b8d501 (diff)
firefox_3.5.2.bb : add newest version of firefox
Diffstat (limited to 'recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch')
-rw-r--r--recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch b/recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch
new file mode 100644
index 0000000000..d1d740989e
--- /dev/null
+++ b/recipes/mozilla/firefox-3.5.2/jemalloc-tls.patch
@@ -0,0 +1,28 @@
+--- /tmp/jemalloc.c 2008-06-23 10:57:36.000000000 +0200
++++ mozilla/memory/jemalloc/jemalloc.c 2008-06-23 11:20:13.000000000 +0200
+@@ -386,7 +386,7 @@
+ #else
+ # define NO_TLS
+ #endif
+-#if 0
++
+ #ifdef __i386__
+ # define QUANTUM_2POW_MIN 4
+ # define SIZEOF_PTR_2POW 2
+@@ -420,7 +420,6 @@
+ # define QUANTUM_2POW_MIN 4
+ # define SIZEOF_PTR_2POW 2
+ #endif
+-#endif
+
+ #define SIZEOF_PTR (1U << SIZEOF_PTR_2POW)
+
+@@ -2582,7 +2581,7 @@
+ * knowledge of how _pthread_self() calculates values, we can't
+ * easily do much better than this.
+ */
+- ind = (unsigned long) _pthread_self() % narenas;
++ ind = 255255 % narenas;
+
+ /*
+ * Optimistially assume that arenas[ind] has been initialized.