summaryrefslogtreecommitdiff
path: root/recipes/midpath/files
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-09-07 19:08:14 -0700
committerKhem Raj <raj.khem@gmail.com>2010-09-07 19:08:14 -0700
commitb389158b1194810db0f4249581c839729271cab5 (patch)
tree1301f83286e5ddbaf0b760457ad1ed8e6157dc3c /recipes/midpath/files
parentb095bd20734460c03710f19f4a38a180c5ecebc9 (diff)
midpath-core_0.2+0.3rc2.bb: Fix compilation error and QA HASH error on ARM
* Remove legacy staging Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/midpath/files')
-rw-r--r--recipes/midpath/files/hci_read_local_name.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/midpath/files/hci_read_local_name.patch b/recipes/midpath/files/hci_read_local_name.patch
new file mode 100644
index 0000000000..e4ce11464a
--- /dev/null
+++ b/recipes/midpath/files/hci_read_local_name.patch
@@ -0,0 +1,13 @@
+Index: midpath-0.3rc2/external/avetanabt-cldc/native/de_avetana_bluetooth_stack_BlueZ.cpp
+===================================================================
+--- midpath-0.3rc2.orig/external/avetanabt-cldc/native/de_avetana_bluetooth_stack_BlueZ.cpp 2010-09-07 18:49:11.000000000 -0700
++++ midpath-0.3rc2/external/avetanabt-cldc/native/de_avetana_bluetooth_stack_BlueZ.cpp 2010-09-07 18:51:52.877682002 -0700
+@@ -649,7 +649,7 @@ JNIEXPORT jstring JNICALL Java_de_avetan
+
+ //printf("Function called: %s, %i\n"__FILE__, __LINE__);
+
+- if (hci_local_name(dd, sizeof(name_str), name_str, timeOut) < 0)
++ if (hci_read_local_name(dd, sizeof(name_str), name_str, timeOut) < 0)
+ {
+ throwException(env, "Java_de_avetana_bluetooth_stack_BlueZ_hciLocalName: Unable to read local name");
+ return 0;