summaryrefslogtreecommitdiff
path: root/recipes/maemo/osso-af-startup_0.28-1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/maemo/osso-af-startup_0.28-1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/maemo/osso-af-startup_0.28-1.bb')
-rw-r--r--recipes/maemo/osso-af-startup_0.28-1.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/maemo/osso-af-startup_0.28-1.bb b/recipes/maemo/osso-af-startup_0.28-1.bb
new file mode 100644
index 0000000000..7727692e06
--- /dev/null
+++ b/recipes/maemo/osso-af-startup_0.28-1.bb
@@ -0,0 +1,45 @@
+LICENSE = "unknown"
+PR = "r4"
+
+PACKAGES= "${PN} osso-af-services osso-af-base-apps"
+DEPENDS = ""
+RDEPENDS_osso-af-services = "${PN}"
+RDEPENDS_osso-af-base-apps = "${PN}"
+
+SRC_URI = "http://stage.maemo.org:80/pool/maemo/ossw/source/o/${PN}/${PN}_${PV}.tar.gz \
+ file://osso-af-startup-source.patch;patch=1;pnum=0 \
+ file://launch-no-o.patch;patch=1;pnum=0"
+
+S = "${WORKDIR}/${PN}-0.28"
+
+FILES_${PN} = "${sysconfdir}/osso-af-init ${sysconfdir}/init.d/af-startup"
+FILES_osso-af-services = "${sysconfdir}/init.d/af-services"
+FILES_osso-af-base-apps = "${sysconfdir}/init.d/af-base-apps"
+
+INITSCRIPT_PACKAGES = "${PACKAGES}"
+INITSCRIPT_NAME_${PN} = "af-startup"
+INITSCRIPT_PARAMS_${PN} = "defaults 50"
+INITSCRIPT_NAME_osso-af-services = "af-services"
+INITSCRIPT_PARAMS_osso-af-services = "defaults 22"
+INITSCRIPT_NAME_osso-af-base-apps = "af-base-apps"
+INITSCRIPT_PARAMS_osso-af-base-apps = "defaults 51"
+
+inherit autotools update-rc.d
+
+do_install () {
+ install -d ${D}${sysconfdir}/osso-af-init
+ install -m 755 ${S}/services/af-defines.sh ${D}/${sysconfdir}/osso-af-init/af-defines.sh
+ install -m 755 ${S}/services/dbus-sessionbus.sh ${D}/${sysconfdir}/osso-af-init/dbus-sessionbus.sh
+ install -m 755 ${S}/services/launch-wrapper.sh ${D}/${sysconfdir}/osso-af-init/launch-wrapper.sh
+ install -m 755 ${S}/services/locale ${D}/${sysconfdir}/osso-af-init/locale
+ install -m 755 ${S}/services/nice-launch-wrapper-tryrestart.sh ${D}/${sysconfdir}/osso-af-init/nice-launch-wrapper-tryrestart.sh
+ install -m 755 ${S}/services/nice-launch-wrapper.sh ${D}/${sysconfdir}/osso-af-init/nice-launch-wrapper.sh
+ install -m 755 ${S}/services/real-af-base-apps ${D}/${sysconfdir}/osso-af-init/real-af-base-apps
+ install -m 755 ${S}/services/real-af-services ${D}/${sysconfdir}/osso-af-init/real-af-services
+ install -m 755 ${S}/services/real-af-startup ${D}/${sysconfdir}/osso-af-init/real-af-startup
+
+ install -d ${D}${sysconfdir}/init.d
+ install -m 755 ${S}/top-scripts/af-base-apps ${D}/${sysconfdir}/init.d/af-base-apps
+ install -m 755 ${S}/top-scripts/af-services ${D}/${sysconfdir}/init.d/af-services
+ install -m 755 ${S}/top-scripts/af-startup ${D}/${sysconfdir}/init.d/af-startup
+}