summaryrefslogtreecommitdiff
path: root/recipes/lua/lua5.1-native_5.1.4.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-24 11:27:54 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-24 12:14:55 +0200
commitbdc8f0323b05966c3533ab72614ddafe257a8352 (patch)
tree9b99da7e609ba1eaab7ef1ff789a8d79c77eaca3 /recipes/lua/lua5.1-native_5.1.4.bb
parent6d1554ecf044484e5e21e34f4b9700e07562cf64 (diff)
lua 5.1: attempt to get in in a buildable state again
Diffstat (limited to 'recipes/lua/lua5.1-native_5.1.4.bb')
-rw-r--r--recipes/lua/lua5.1-native_5.1.4.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes/lua/lua5.1-native_5.1.4.bb b/recipes/lua/lua5.1-native_5.1.4.bb
new file mode 100644
index 0000000000..35afb55662
--- /dev/null
+++ b/recipes/lua/lua5.1-native_5.1.4.bb
@@ -0,0 +1,11 @@
+require lua5.1_${PV}.bb
+inherit native
+
+DEPENDS = "readline-native"
+
+do_stage () {
+ oe_libinstall -C src liblua ${STAGING_LIBDIR}/
+ install -d ${STAGING_INCDIR}/
+ install -m 0644 src/lua.h src/luaconf.h src/lualib.h src/lauxlib.h ${STAGING_INCDIR}/
+}
+