summaryrefslogtreecommitdiff
path: root/recipes/llvm/llvm_2.5.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-03-25 18:29:54 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2009-03-25 18:29:54 +0100
commit95e0882e2dfabe457550a885e0eb24893df31742 (patch)
treea34220ed25168022c53d9cb5697f3666a427b30c /recipes/llvm/llvm_2.5.bb
parent451b1c687105655a4f2c9c477b05535041e25060 (diff)
parentac41ae95b1dbe54c05adf494c0fa44b3abbfeca3 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/llvm/llvm_2.5.bb')
-rw-r--r--recipes/llvm/llvm_2.5.bb12
1 files changed, 7 insertions, 5 deletions
diff --git a/recipes/llvm/llvm_2.5.bb b/recipes/llvm/llvm_2.5.bb
index c0ce3345b8..ece64422b5 100644
--- a/recipes/llvm/llvm_2.5.bb
+++ b/recipes/llvm/llvm_2.5.bb
@@ -1,7 +1,3 @@
-# TODO:
-# - packages examples
-# - fix staging (and probably llvm-config script)
-
DESCRIPTION = "The Low Level Virtual Machine"
HOMEPAGE = "http://llvm.org"
LICENSE = "various"
@@ -11,6 +7,8 @@ SRC_URI = "\
file://fix-build.patch;patch=1 \
"
+PR = "r2"
+
DEPENDS = "llvm-native"
inherit cmake
@@ -30,7 +28,11 @@ EXTRA_OECMAKE = "\
"
do_stage() {
- oe_runmake DESTDIR="${STAGE_TEMP}" install
+ oe_runmake DESTDIR="${STAGING_DIR_HOST}" install
+
+ install -d ${STAGING_INCDIR}/llvm
+ find include/llvm -name "*.h" -maxdepth 1 -exec \
+ install {} ${STAGING_INCDIR}/llvm \;
install -d ${STAGING_BINDIR_CROSS}