summaryrefslogtreecommitdiff
path: root/recipes/llvm/llvm_2.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/llvm/llvm_2.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/llvm/llvm_2.4.bb')
-rw-r--r--recipes/llvm/llvm_2.4.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes/llvm/llvm_2.4.bb b/recipes/llvm/llvm_2.4.bb
new file mode 100644
index 0000000000..a66d1b376b
--- /dev/null
+++ b/recipes/llvm/llvm_2.4.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "The Low Level Virtual Machine"
+HOMEPAGE = "http://llvm.org"
+LICENSE = "various"
+
+SRC_URI = "\
+ http://llvm.org/releases/${PV}/llvm-${PV}.tar.gz \
+ file://fix-build.patch;patch=1 \
+ file://fix-static-initialization.patch;patch=1 \
+ "
+
+DEPENDS = "llvm-native"
+
+inherit autotools
+
+# --enable-debug-runtime disables automatic stripping and lets
+# OE control that
+EXTRA_OECONF += "--enable-debug-runtime --enable-targets=host-only"
+
+do_compile() {
+ # The build wants these binaries, together with the build-fix patch
+ # they are not compiled again (which would not work).
+ # Most important aspect is removing BUILD_TARGET_DIRS variable.
+ install -d Release/Build/bin
+ cp ${STAGING_BINDIR_NATIVE}/tblgen Release/Build/bin
+ cp ${STAGING_BINDIR_NATIVE}/fpcmp Release/Build/bin
+ cp ${STAGING_BINDIR_NATIVE}/llvm-PerfectShuffle Release/Build/bin
+
+ oe_runmake
+}
+
+do_stage() {
+ autotools_stage_all
+
+ rm ${STAGING_LIBDIR}/LLVMHello.*
+
+ install -d ${STAGING_BINDIR_CROSS}
+
+ sed -e's^my.*ABS_RUN_DIR =.*^my $ABS_RUN_DIR = "${STAGING_DIR_TARGET}";^' \
+ -e's^my.*INCLUDEDIR =.*^my $INCLUDEDIR = "${STAGING_INCDIR}";^' \
+ -e's^my.*LIBDIR.*^my $LIBDIR = "${STAGING_LIBDIR}";^' \
+ -e's^my.*BINDIR.*^my $BINDIR = "${STAGING_BINDIR}";^' \
+ Release/Host/bin/llvm-config > ${STAGING_BINDIR_CROSS}/llvm-config
+
+ chmod +x ${STAGING_BINDIR_CROSS}/llvm-config
+}
+