summaryrefslogtreecommitdiff
path: root/recipes/llvm/llvm2.7_2.6+svnr20090916.bb
diff options
context:
space:
mode:
authorXerxes Rånby <xerxes@zafena.se>2009-09-17 11:27:17 +0200
committerXerxes Rånby <xerxes@zafena.se>2009-09-17 11:37:41 +0200
commit718a561ceb1e9668678faaa863b65f670bf7015e (patch)
treef2b14937b53db7f4f700cdfe532c4ba3023d949d /recipes/llvm/llvm2.7_2.6+svnr20090916.bb
parent05a753b24b94d4b1db756356820e3913a2e702bb (diff)
llvm 2.7: New recipe.
llvm-native 2.7: Likewise.
Diffstat (limited to 'recipes/llvm/llvm2.7_2.6+svnr20090916.bb')
-rw-r--r--recipes/llvm/llvm2.7_2.6+svnr20090916.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/llvm/llvm2.7_2.6+svnr20090916.bb b/recipes/llvm/llvm2.7_2.6+svnr20090916.bb
new file mode 100644
index 0000000000..022657c5ff
--- /dev/null
+++ b/recipes/llvm/llvm2.7_2.6+svnr20090916.bb
@@ -0,0 +1,24 @@
+require llvm.inc
+
+SRCREV = "82130"
+
+PV = "2.6+svnr${SRCREV}"
+
+PR = "r0"
+
+DEPENDS = "llvm-common llvm2.7-native"
+
+SRC_URI = "\
+ svn://llvm.org/svn/llvm-project/llvm/;proto=http;module=trunk \
+ file://llvm-debugonly-zeroormore.patch;patch=1 \
+"
+
+EXTRA_OECMAKE += "\
+ -DLLVM_TARGET_ARCH:STRING=${LLVM_ARCH} \
+ -DLLVM_ENABLE_ASSERTIONS:BOOL=ON \
+ -DCMAKE_BUILD_TYPE:STRING=RelWithDebInfo \
+ "
+
+S = "${WORKDIR}/trunk"
+
+LLVM_RELEASE = "2.7"