summaryrefslogtreecommitdiff
path: root/recipes/linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-01 01:19:41 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-01 01:19:41 +0200
commit107327eb915d948740dafae15e7cdbf81b8c59c1 (patch)
tree99056011bf66fdbbc8c6665db10eaba507faa33c /recipes/linux
parentcaa7a37b973c1bd178f519d9fd5460e0bc040fc3 (diff)
parent7354ce1960407a294d76edaab5e34a98d888c2b1 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/linux')
-rw-r--r--recipes/linux/linux-davinci_2.6.30.bb34
-rw-r--r--recipes/linux/linux-davinci_git.bb4
2 files changed, 36 insertions, 2 deletions
diff --git a/recipes/linux/linux-davinci_2.6.30.bb b/recipes/linux/linux-davinci_2.6.30.bb
new file mode 100644
index 0000000000..63c87e820b
--- /dev/null
+++ b/recipes/linux/linux-davinci_2.6.30.bb
@@ -0,0 +1,34 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for Davinci processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "(dm6446-evm|dm6467-evm|dm355-evm|davinci-sffsdr|dm355-leopard)"
+
+DEFAULT_PREFERENCE = "1"
+
+SRCREV = "5212151f26e688416faac9f6f33ddd958f7de96c"
+
+# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
+PV = "2.6.30-${PR}+gitr${SRCREV}"
+
+SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-davinci.git;protocol=git \
+ file://defconfig"
+
+# Need checking
+SRC_URI_append_davinci-sffsdr = " \
+ file://0001-USB-musb-cppi-bugfixes.patch;patch=1 \
+ file://0002-ARM-Mark-unsupported-syscalls-as-IGNORE.patch;patch=1 \
+ file://0003-Add-macros-for-enabling-a-UART.patch;patch=1 \
+ file://0004-Davinci-Enable-MAC-address-to-be-specified-on-kerne.patch;patch=1 \
+ file://0005-Add-DAS-Mini-DAS-and-AFE-USB-machine-types.patch;patch=1 \
+ file://0006-ALSA-ASoC-DaVinci-Fix-SFFSDR-compilation-error.patch;patch=1 \
+ file://0007-ALSA-ASoC-Davinci-Fix-SFFSDR-FPGA-module-codec-FS.patch;patch=1 \
+ file://0008-ALSA-ASoC-Davinci-Fix-incorrect-machine-type-for.patch;patch=1 \
+ file://0009-sound-ASoC-Fix-DaVinci-module-unload-error.patch;patch=1 \
+ file://0010-Add-generic-FPGA-bitstream-loader-driver.patch;patch=1 \
+ file://0011-Add-lyrvpss-example-driver-for-the-SFFSDR-board.patch;patch=1 \
+ file://0012-Update-SFFSDR-to-support-FPGA-and-lyrvpss-drivers.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/git"
diff --git a/recipes/linux/linux-davinci_git.bb b/recipes/linux/linux-davinci_git.bb
index 7af90fa440..a39ba10d7a 100644
--- a/recipes/linux/linux-davinci_git.bb
+++ b/recipes/linux/linux-davinci_git.bb
@@ -7,10 +7,10 @@ COMPATIBLE_MACHINE = "(dm6446-evm|dm6467-evm|dm355-evm|davinci-sffsdr|dm355-leop
DEFAULT_PREFERENCE = "1"
-SRCREV = "03022e38318bef016836dae71c70b9ea975723e7"
+SRCREV = "5bbb6571043c7e3a1d73b874334037a64d10612f"
# The main PR is now using MACHINE_KERNEL_PR, for davinci see conf/machine/include/davinci.inc
-PV = "2.6.29+2.6.30-rc7-${PR}+gitr${SRCREV}"
+PV = "2.6.30-${PR}+gitr${SRCREV}"
SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/khilman/linux-davinci.git;protocol=git;branch=staging/vpfe \
file://defconfig"