summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-storcenter_2.6.27.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-storcenter_2.6.27.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-storcenter_2.6.27.7.bb')
-rw-r--r--recipes/linux/linux-storcenter_2.6.27.7.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes/linux/linux-storcenter_2.6.27.7.bb b/recipes/linux/linux-storcenter_2.6.27.7.bb
new file mode 100644
index 0000000000..b403cda2ab
--- /dev/null
+++ b/recipes/linux/linux-storcenter_2.6.27.7.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "Linux Kernel for the IOMega StorCenter"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r2"
+
+DEPENDS = "dtc-native"
+COMPATIBLE_MACHINE = "storcenter"
+
+SRC_URI = "http://kernel.org/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://fw-and-powerpc-install.patch;patch=1 \
+ file://defconfig-${PV} \
+ "
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+export ARCH="powerpc"
+
+KERNEL_IMAGETYPE = "uImage"
+
+FILES_kernel-image += "/boot/storcenter.dtb"
+
+do_configure() {
+ mkdir -p ${IMAGE_ROOTFS}
+ install -m 0644 ${WORKDIR}/defconfig-${PV} ${S}/.config
+ ARCH=${ARCH} oe_runmake oldconfig
+}
+
+do_install_append() {
+ rm -f ${D}/boot/vmlinux-*
+ dtc -f -I dts -O dtb -o ${D}/boot/storcenter.dtb -V 16 ${S}/arch/${ARCH}/boot/dts/storcenter.dts
+}
+
+do_builtin_initramfs_foonas() {
+ :
+}
+
+pkg_preinst_foonas() {
+ if [ "x$D" != "x" ]; then
+ ln -sf ${KERNEL_IMAGETYPE}-${PV} ${D}/boot/uImage
+ exit 1
+ fi
+
+ rm -f /boot/uImage
+ ln -sf ${KERNEL_IMAGETYPE}-${PV} /boot/uImage
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 ${S}/arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/vmlinux.UBoot
+ install -m 0644 ${D}/boot/storcenter.dtb ${DEPLOY_DIR_IMAGE}/storcenter.dtb
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_package after do_install