summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-openmoko-shr-drm-devel_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:02:11 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:08 +0100
commitd977d3744d720085b2d4c0959189ef18b1517318 (patch)
tree8efcb80fcc2221850bf605389d2c3d847e36abbb /recipes/linux/linux-openmoko-shr-drm-devel_git.bb
parentdb1b0c20612bc91df53b3654b2b9256b82f382fa (diff)
linux-openmoko-shr-drm: new recipe for 2.6.29-rc3 kernel with DRM/KMS support
Diffstat (limited to 'recipes/linux/linux-openmoko-shr-drm-devel_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-shr-drm-devel_git.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-shr-drm-devel_git.bb b/recipes/linux/linux-openmoko-shr-drm-devel_git.bb
new file mode 100644
index 0000000000..12627cdf43
--- /dev/null
+++ b/recipes/linux/linux-openmoko-shr-drm-devel_git.bb
@@ -0,0 +1,35 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+
+DEFAULT_PREFERENCE = "-1"
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3-drm"
+
+OMV = "oe14"
+PV = "${KERNEL_RELEASE}-drm-${OMV}+gitr${SRCPV}"
+PR = "r2"
+
+SRC_URI = "\
+# git://git.openmoko.org/git/kernel.git;protocol=git;branch=drm-tracking \
+ git://git.bitwiz.org.uk/kernel.git;protocol=git;branch=kms-tests \
+ file://fix-install.patch;patch=1 \
+ file://0001-Add-drm-to-Makefile-version.patch;patch=1 \
+ file://0001-Fix-s3c-adc-suspend.patch;patch=1 \
+ file://0002-GTA01-GTA02-disable-android-drivers-in-default-confi.patch;patch=1 \
+ file://0003-glamo-spi-missing-semicolon-after-MODULE_AUTHOR.patch;patch=1 \
+ file://0004-gta02_drm_defconfig-start-from-gta02_packaging_defco.patch;patch=1 \
+ file://0005-Enable-DRM-and-MFD_GLAMO_DRM.patch;patch=1 \
+ file://0006-Enable-I2C_ALGOBIT-from-make-oldconfig.patch;patch=1 \
+ file://0007-Enable-UBI-UBIFS.patch;patch=1 \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_drm_defconfig"
+CONFIG_NAME_om-gta03 = "gta03_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+}