summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-openmoko-shr-devel_git.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-24 16:33:51 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-24 16:33:51 +0000
commit9a681a2affece3d2a9230c4939450d9392c33bf9 (patch)
tree15f0a38d8bdee1eb0e9bae2e6277b03c28bd3fe8 /recipes/linux/linux-openmoko-shr-devel_git.bb
parent880e00d3b7ccf66d9421a06bc28e553e07842b59 (diff)
parenta12117346588829898e6a041a4432fb0370c0c76 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded
Diffstat (limited to 'recipes/linux/linux-openmoko-shr-devel_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-shr-devel_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-shr-devel_git.bb b/recipes/linux/linux-openmoko-shr-devel_git.bb
new file mode 100644
index 0000000000..26a995d0b8
--- /dev/null
+++ b/recipes/linux/linux-openmoko-shr-devel_git.bb
@@ -0,0 +1,26 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
+OMV = "oe11"
+PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCREV}"
+PR = "r5"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://fix-install.patch;patch=1 \
+ file://0007-Enable-UBI-UBIFS.patch;patch=1 \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+CONFIG_NAME_om-gta03 = "gta03_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+}