summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-openmoko-shr-devel_git.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-11-18 09:15:55 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-11-18 09:15:55 +0000
commit15387c72d5cf1a77a5a0afa6750dae73a8dbc12f (patch)
treeab55e077002322c8f245c79c87c6a6f2f7b0ed2e /recipes/linux/linux-openmoko-shr-devel_git.bb
parent7f3d2b172af63fc894f80eece075434b2c5fbbc5 (diff)
parente4e52ba358c094952ec868d32524a26dfa4bae89 (diff)
Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/linux/linux-openmoko-shr-devel_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-shr-devel_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-shr-devel_git.bb b/recipes/linux/linux-openmoko-shr-devel_git.bb
new file mode 100644
index 0000000000..4f300ff73a
--- /dev/null
+++ b/recipes/linux/linux-openmoko-shr-devel_git.bb
@@ -0,0 +1,26 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
+OMV = "oe11"
+PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCPV}"
+PR = "r3.5"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://fix-install.patch;patch=1 \
+ file://0007-Enable-UBI-UBIFS.patch;patch=1 \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+CONFIG_NAME_om-gta03 = "gta03_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+}