summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-openmoko-shr-devel_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:02:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:09 +0100
commit861528cf2fb788795b49eab18716932565dd93cd (patch)
tree8b0620da00767737bed738b0182682dfdbb21288 /recipes/linux/linux-openmoko-shr-devel_git.bb
parentd977d3744d720085b2d4c0959189ef18b1517318 (diff)
linux-openmoko-shr: new recipe for 2.6.29-rc3 kernel
Diffstat (limited to 'recipes/linux/linux-openmoko-shr-devel_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-shr-devel_git.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-shr-devel_git.bb b/recipes/linux/linux-openmoko-shr-devel_git.bb
new file mode 100644
index 0000000000..4f300ff73a
--- /dev/null
+++ b/recipes/linux/linux-openmoko-shr-devel_git.bb
@@ -0,0 +1,26 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.29"
+KERNEL_VERSION = "2.6.29-rc3"
+
+OMV = "oe11"
+PV = "${KERNEL_RELEASE}-${OMV}+gitr${SRCPV}"
+PR = "r3.5"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=andy-tracking \
+ file://fix-install.patch;patch=1 \
+ file://0007-Enable-UBI-UBIFS.patch;patch=1 \
+"
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_moredrivers_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_packaging_defconfig"
+CONFIG_NAME_om-gta03 = "gta03_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+}