summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-openmoko-2.6.31_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:00:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2009-11-18 09:57:06 +0100
commitdb1b0c20612bc91df53b3654b2b9256b82f382fa (patch)
treec6bcb21cb706406b1f90550b6e00a46593776966 /recipes/linux/linux-openmoko-2.6.31_git.bb
parentbb0afba8d281a03f5bf21bc4a29ac495a342cc6d (diff)
linux-openmoko-2.6.31: new recipe for 2.6.31 kernel from SHR
Diffstat (limited to 'recipes/linux/linux-openmoko-2.6.31_git.bb')
-rw-r--r--recipes/linux/linux-openmoko-2.6.31_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/linux/linux-openmoko-2.6.31_git.bb b/recipes/linux/linux-openmoko-2.6.31_git.bb
new file mode 100644
index 0000000000..3d6a84b81d
--- /dev/null
+++ b/recipes/linux/linux-openmoko-2.6.31_git.bb
@@ -0,0 +1,27 @@
+require linux.inc
+require linux-openmoko.inc
+
+DESCRIPTION_${PN} = "Linux ${KERNEL_VERSION} kernel for the Openmoko Neo GSM Smartphones"
+
+KERNEL_RELEASE = "2.6.31"
+KERNEL_VERSION = "${KERNEL_RELEASE}"
+
+OEV = "oe1"
+PV = "${KERNEL_RELEASE}-${OEV}+gitr${SRCPV}"
+PR = "r1"
+
+SRC_URI = "\
+ git://git.openmoko.org/git/kernel.git;protocol=git;branch=om-2.6.31 \
+ file://0001-wm8753-fix-build-with-gcc-4.4.2-which-works-ok-with-.patch;patch=1 \
+ file://0004-gta02_defconfig-Enable-UBI-support.patch;patch=1 \
+ file://0005-gta02_defconfig-Enable-UBI-debug.patch;patch=1 \
+"
+
+S = "${WORKDIR}/git"
+
+CONFIG_NAME_om-gta01 = "gta01_defconfig"
+CONFIG_NAME_om-gta02 = "gta02_defconfig"
+
+do_configure_prepend() {
+ install -m 644 ./arch/arm/configs/${CONFIG_NAME} ${WORKDIR}/defconfig-oe
+}