summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-omap-psp_2.6.29.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-23 17:32:09 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-23 17:32:09 +0200
commit6dabb1c806e24a2e31d3294327d3eb3e87a347e3 (patch)
tree940f0d00e73555df49f8084183c8fa18fc7a5760 /recipes/linux/linux-omap-psp_2.6.29.bb
parentfae2d88eb20c5d80cc48743c556c5c532afc7304 (diff)
linux-omap psp: add 'psp' kernel from TI to make it easier to do side-by-side comparisons of mainline and TI
Diffstat (limited to 'recipes/linux/linux-omap-psp_2.6.29.bb')
-rw-r--r--recipes/linux/linux-omap-psp_2.6.29.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/linux/linux-omap-psp_2.6.29.bb b/recipes/linux/linux-omap-psp_2.6.29.bb
new file mode 100644
index 0000000000..322aa7c4dc
--- /dev/null
+++ b/recipes/linux/linux-omap-psp_2.6.29.bb
@@ -0,0 +1,33 @@
+require linux.inc
+
+DESCRIPTION = "Linux kernel for OMAP processors"
+KERNEL_IMAGETYPE = "uImage"
+
+COMPATIBLE_MACHINE = "omap3evm"
+
+SRCREV = "9abb6eb717acbca192ab251a056e3a66b2b47884"
+
+# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
+PR_append = "+gitr${SRCREV}"
+
+SRC_URI = "git://arago-project.org/git/people/sriram/ti-psp-omap.git;protocol=git;branch=int_030000_build3 \
+ file://defconfig"
+
+S = "${WORKDIR}/git"
+
+SRC_URI_append = " \
+ file://fix-twl-merge-damage.diff;patch=1 \
+ file://fix-section-mismatch.diff;patch=1 \
+"
+
+do_install_append() {
+ install -d ${D}/boot
+ install -m 0644 Documentation/arm/OMAP/DSS ${D}/boot/
+}
+
+PACKAGES =+ "omap-dss-doc"
+FILES_omap-dss-doc = "/boot/DSS"
+
+module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
+
+