summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-ks8695_2.6.16.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-ks8695_2.6.16.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-ks8695_2.6.16.bb')
-rw-r--r--recipes/linux/linux-ks8695_2.6.16.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/linux/linux-ks8695_2.6.16.bb b/recipes/linux/linux-ks8695_2.6.16.bb
new file mode 100644
index 0000000000..a357443fdb
--- /dev/null
+++ b/recipes/linux/linux-ks8695_2.6.16.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Linux kernel for Micrel KS8695(P) based devices"
+SECTION = "kernel"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://ks8695-headers-r0.patch;patch=1 \
+ file://ks8695-base-r0.patch;patch=1 \
+ file://defconfig-ks8695"
+
+S = "${WORKDIR}/linux-${PV}"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+COMPATIBLE_MACHINE = "ks8695"
+
+inherit kernel
+inherit package
+
+ARCH = "arm"
+CMDLINE = "ttyS0,115200n8 root=/dev/mtdblock2 init=/linuxrc"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig-${MACHINE} ${S}/.config
+ echo "CONFIG_CMDLINE=\"${CMDLINE}\"" >> ${S}/.config
+}