summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-kirkwood_2.6.33-rc5.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-01-29 22:29:38 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-01-29 22:29:38 +0100
commit9a3aceee4861e3b79ad8c73a01b4e4a93e421c0b (patch)
treed76ed6021b6b45d643a027b3e5172f3399f2d8fc /recipes/linux/linux-kirkwood_2.6.33-rc5.bb
parent61acb940a7436a43d0894284d25e8d106f461c23 (diff)
linux-kirkwood: updated to 2.6.33-rc5; updated video patch; added tgt as module
- added a recipe for 2.6.33-rc5 - updated video patch (as provided by einfochips) - made use of the PR bump to add building tgt as module in defconifg Signed-off-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-kirkwood_2.6.33-rc5.bb')
-rw-r--r--recipes/linux/linux-kirkwood_2.6.33-rc5.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/linux/linux-kirkwood_2.6.33-rc5.bb b/recipes/linux/linux-kirkwood_2.6.33-rc5.bb
new file mode 100644
index 0000000000..b1640820d7
--- /dev/null
+++ b/recipes/linux/linux-kirkwood_2.6.33-rc5.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Linux Kernel for Marvell Kirkwood based devices"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+COMPATIBLE_MACHINE = "openrd-base|openrd-client|sheevaplug"
+
+require linux.inc
+
+# Change MACHINE_KERNEL_PR in conf/machine/include/kirkwood.inc
+PV = "2.6.32+2.6.33-rc5"
+
+SRCREV = "6a18e42f474250ab3cf7705f34b048c6d55797e5"
+
+SRC_URI = "git://repo.or.cz/linux-2.6/linux-2.6-openrd.git;protocol=git \
+ file://defconfig"
+
+SRC_URI_append_openrd-base += " \
+ file://openrd-base/openrd-base-enable-pcie.patch;patch=1 \
+ file://0004-ARM-Kirkwood-OpenRD-SD-UART1-selection.patch;patch=1 \
+ "
+
+SRC_URI_append_openrd-client += " \
+ file://0001-OpenRD-Client-PCIe-Initialize-PCI-express-and-i2c.patch;patch=1 \
+ file://0002-OpenRD-Client-Volari-Z11-driver-added.patch;patch=1 \
+ file://0003-ARM-Kirkwood-Sound-Sound-driver-added.patch;patch=1 \
+ file://0004-ARM-Kirkwood-OpenRD-SD-UART1-selection.patch;patch=1 \
+ "
+
+# update machine types list for ARM architecture, only for machines that need it
+do_arm_mach_types() {
+# if test ${MACHINE} == openrd-base || test ${MACHINE} == openrd-client; then
+ curl -o mach-types "http://www.arm.linux.org.uk/developer/machines/download.php" && \
+ cp mach-types arch/arm/tools/mach-types
+# fi
+}
+
+addtask arm_mach_types after do_patch before do_configure
+
+S = "${WORKDIR}/git"
+
+KERNEL_IMAGETYPE ?= "uImage"
+