summaryrefslogtreecommitdiff
path: root/recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb')
-rw-r--r--recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb b/recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb
new file mode 100644
index 0000000000..b6cdf48144
--- /dev/null
+++ b/recipes/linux/chumby-kernel_2.6.16-chumby-1.2.bb
@@ -0,0 +1,45 @@
+require linux.inc
+
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for the Chumby"
+LICENSE = "GPL"
+PR = "r4"
+
+SRC_URI = "http://files.chumby.com/source/ironforge/build396/linux-2.6.16-chumby-1.2.tar.gz \
+ http://files.chumby.com/source/ironforge/build396/align.pl \
+ file://chumby-override-cmdline.patch;patch=1 \
+ file://disable-fbchanging.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.16"
+
+COMPATIBLE_HOST = 'arm.*-linux'
+
+ARCH = "arm"
+
+# Use this CMDLINE for booting from RootFS 1 on the internal flash (22MB)
+#CMDLINE = "console=ttyS0,38400 console=tty0 root=/dev/mtdblock5 rootfstype=jffs2 psplash=false"
+
+# Use this CMDLINE for booting from the second partition of an USB disk
+CMDLINE = "console=ttyS0,38400 console=tty0 root=/dev/sda2 rootfstype=ext2 rootdelay=8 psplash=false"
+
+COMPATIBLE_MACHINE = "chumby"
+
+module_autoload_chumby_accel = "chumby_accel"
+module_autoload_chumby_emma = "chumby_emma"
+module_autoload_chumby_sense1 = "chumby_sense1"
+module_autoload_chumby_timer = "chumby_timer"
+module_autoload_chumby_udma = "chumby_udma"
+module_autoload_chumby-tsc2100 = "chumby-tsc2100"
+
+do_deploy_prepend() {
+ perl ../align.pl arch/arm/boot/zImage
+}
+
+do_deploy_append() {
+ rm -f ${DEPLOY_DIR_IMAGE}/zImage-${PV}-${PR}-${MACHINE}.bin.zip
+ zip ${DEPLOY_DIR_IMAGE}/zImage-${PV}-${PR}-${MACHINE}.bin.zip ${DEPLOY_DIR_IMAGE}/zImage-${PV}-${PR}-${MACHINE}.bin
+ ln -sf zImage-${PV}-${PR}-${MACHINE}.bin.zip ${DEPLOY_DIR_IMAGE}/zImage-${MACHINE}.bin.zip
+}
+