summaryrefslogtreecommitdiff
path: root/recipes/lineak/lineak_0.8.3.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/lineak/lineak_0.8.3.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/lineak/lineak_0.8.3.bb')
-rw-r--r--recipes/lineak/lineak_0.8.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/lineak/lineak_0.8.3.bb b/recipes/lineak/lineak_0.8.3.bb
new file mode 100644
index 0000000000..d26ef7bb56
--- /dev/null
+++ b/recipes/lineak/lineak_0.8.3.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "lineakd"
+SECTION = "gpe/multimedia"
+HOMEPAGE = "http://lineak.sourceforge.net"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libx11 libxext"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lineak/lineakd-${PV}.tar.gz \
+ file://add-zaurus-remote-support.patch;patch=1"
+S = "${WORKDIR}/lineakd-${PV}"
+
+inherit autotools
+
+do_install () {
+ oe_runmake 'mandir=${D}/usr/share/man' 'pkglibdir=${D}/usr/lib' 'sysconfdir=${D}/etc' 'DESTDIR=${D}' install
+}
+
+PACKAGES += "${PN}-lib"
+
+FILES_${PN}-lib += " \
+ ${libdir}/liblineak*"
+