summaryrefslogtreecommitdiff
path: root/recipes/lighttpd/lighttpd_1.4.18.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2009-10-06 12:18:37 +0200
committerHenning Heinold <heinold@inf.fu-berlin.de>2009-10-06 12:46:13 +0200
commit46243e2ac292b0cc015b7811a802df11f3fa2fe6 (patch)
treea17b82dbad8bcfc16c48908195bbe4373f4068a9 /recipes/lighttpd/lighttpd_1.4.18.bb
parent1c7fac5c2ade328c197973fdaa717efe44c2532c (diff)
lighttpd: switch to .inc file and INC_PR
Diffstat (limited to 'recipes/lighttpd/lighttpd_1.4.18.bb')
-rw-r--r--recipes/lighttpd/lighttpd_1.4.18.bb52
1 files changed, 6 insertions, 46 deletions
diff --git a/recipes/lighttpd/lighttpd_1.4.18.bb b/recipes/lighttpd/lighttpd_1.4.18.bb
index d5870ba5af..3d47a211cf 100644
--- a/recipes/lighttpd/lighttpd_1.4.18.bb
+++ b/recipes/lighttpd/lighttpd_1.4.18.bb
@@ -1,49 +1,9 @@
-DESCRIPTION = "Web server"
-SECTION = "net"
-LICENSE = "BSD"
-DEPENDS = "libpcre"
-PR = "r3"
+require lighttpd.inc
-SRC_URI = "http://www.lighttpd.net/download/lighttpd-${PV}.tar.gz \
- file://configure.in.patch;patch=1 \
- file://mod_redirect.c.patch;patch=1 \
- file://src-server.c.patch;patch=1 \
- file://index.html \
- file://lighttpd.conf \
- file://lighttpd"
+PR = "${INC_PR}.1"
-EXTRA_OECONF="--without-bzip2 \
- --without-ldap \
- --without-lua \
- --without-memcache \
- --with-pcre \
- --without-webdav-props \
- --without-webdav-locks \
- --without-openssl \
- --disable-nls \
- --disable-static"
+SRC_URI += "file://configure.in.patch;patch=1 \
+ file://mod_redirect.c.patch;patch=1 \
+ file://src-server.c.patch;patch=1 \
+ "
-inherit autotools pkgconfig update-rc.d
-
-INITSCRIPT_NAME = "lighttpd"
-INITSCRIPT_PARAMS = "defaults 70"
-
-do_install_append() {
- install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
- install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
- install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
-}
-
-do_stage() {
- autotools_stage_all
-}
-
-FILES_${PN} += "${sysconfdir} /www"
-
-PACKAGES_DYNAMIC = "lighttpd-module-*"
-
-python populate_packages_prepend () {
- lighttpd_libdir = bb.data.expand('${libdir}', d)
- do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
-}