summaryrefslogtreecommitdiff
path: root/recipes/libxsettings-client/files
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libxsettings-client/files
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libxsettings-client/files')
-rw-r--r--recipes/libxsettings-client/files/make_pkgconfig_x11.patch21
-rw-r--r--recipes/libxsettings-client/files/no-host-includes.patch13
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes/libxsettings-client/files/make_pkgconfig_x11.patch b/recipes/libxsettings-client/files/make_pkgconfig_x11.patch
new file mode 100644
index 0000000000..3a386672d2
--- /dev/null
+++ b/recipes/libxsettings-client/files/make_pkgconfig_x11.patch
@@ -0,0 +1,21 @@
+--- libxsettings-client0-0.12/Makefile.old 2004-04-20 16:48:18.000000000 +1000
++++ libxsettings-client0-0.12/Makefile 2004-04-20 16:58:07.000000000 +1000
+@@ -20,6 +20,9 @@
+ CPPFLAGS += -DPACKAGE=\"$(PACKAGE)\" -DPREFIX=\"$(PREFIX)\" -DPACKAGE_LOCALE_DIR=\"$(PREFIX)/share/locale\"
+ CPPFLAGS += -I../libxsettings
+
++CFLAGS += `pkg-config --cflags x11`
++LDFLAGS += `pkg-config --ldflags x11`
++
+ XSETTINGS_OBJS = $(patsubst %,%.os,$(XSETTINGS_MEMBERS))
+ DEPS = $(patsubst %,%.d,$(MEMBERS) $(XSETTINGS_MEMBERS))
+ SOURCES = $(patsubst %,%.c,$(MEMBERS) $(XSETTINGS_MEMBERS))
+@@ -39,7 +42,7 @@
+ ln -sf $^ $@
+
+ $(LIBXSETTINGS_SO): $(XSETTINGS_OBJS)
+- $(CC) -o $@ $^ -shared -Wl,-soname -Wl,$(LIBXSETTINGS_SO) -nostartfiles -L/usr/X11R6/lib -lX11 -L../libxsettings -lXsettings
++ $(CC) -o $@ $^ -shared -Wl,-soname -Wl,$(LIBXSETTINGS_SO) -nostartfiles $(LDFLAGS) -L../libxsettings -lXsettings
+
+ install-program: $(LIBXSETTINGS_SO)
+ install -d $(DESTDIR)$(PREFIX)/lib
diff --git a/recipes/libxsettings-client/files/no-host-includes.patch b/recipes/libxsettings-client/files/no-host-includes.patch
new file mode 100644
index 0000000000..137c5269f1
--- /dev/null
+++ b/recipes/libxsettings-client/files/no-host-includes.patch
@@ -0,0 +1,13 @@
+Index: libxsettings-client-0.17/Makefile.am
+===================================================================
+--- libxsettings-client-0.17.orig/Makefile.am 2006-05-19 23:14:46.557360552 +0200
++++ libxsettings-client-0.17/Makefile.am 2006-05-19 23:14:56.010923392 +0200
+@@ -3,7 +3,7 @@
+ source_h = xsettings-client.h xsettings-common.h
+ source_c = xsettings-client.c xsettings-common.c
+
+-INCLUDES = -I $(includedir) $(X_CFLAGS)
++INCLUDES = $(X_CFLAGS)
+
+ libxsincludedir = $(includedir)
+