summaryrefslogtreecommitdiff
path: root/recipes/libssh/libssh_0.11.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libssh/libssh_0.11.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libssh/libssh_0.11.bb')
-rw-r--r--recipes/libssh/libssh_0.11.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libssh/libssh_0.11.bb b/recipes/libssh/libssh_0.11.bb
new file mode 100644
index 0000000000..833567ebb0
--- /dev/null
+++ b/recipes/libssh/libssh_0.11.bb
@@ -0,0 +1,35 @@
+SECTION = "libs"
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+DEPENDS = "openssl"
+LICENSE = "LGPL"
+
+DEFAULT_PREFERENCE="-1"
+
+SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
+do_stage () {
+ set -x
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake "prefix=${D}${prefix}" \
+ "exec_prefix=${D}${exec_prefix}" \
+ "bindir=${D}${bindir}" \
+ "incldir=${D}${includedir}" \
+ "infodir=${D}${infodir}" \
+ "mandir=${D}${mandir}/man1" \
+ "libdir=${D}${libdir}" \
+ install
+}