summaryrefslogtreecommitdiff
path: root/recipes/libpcap/libpcap_1.0.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libpcap/libpcap_1.0.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libpcap/libpcap_1.0.0.bb')
-rw-r--r--recipes/libpcap/libpcap_1.0.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/libpcap/libpcap_1.0.0.bb b/recipes/libpcap/libpcap_1.0.0.bb
new file mode 100644
index 0000000000..b85bf4c5d4
--- /dev/null
+++ b/recipes/libpcap/libpcap_1.0.0.bb
@@ -0,0 +1,29 @@
+require libpcap.inc
+
+PR = "r5"
+SRC_URI = "http://www.tcpdump.org/release/libpcap-${PV}.tar.gz"
+SRC_URI += "file://aclocal.patch;patch=1"
+SRC_URI += "file://ieee80215-arphrd.patch;patch=1"
+
+do_compile () {
+ oe_runmake
+ rm -f *.o
+ oe_runmake shared
+}
+
+do_install () {
+ install -d ${D}${libdir}
+ install -d ${D}${bindir}
+ oe_runmake install DESTDIR=${D}
+ oe_runmake install-shared DESTDIR=${D}
+ oe_libinstall -a -so libpcap ${D}${libdir}
+}
+
+do_stage_append () {
+ install -d ${STAGING_INCDIR}/pcap
+ install -m 0644 pcap/pcap.h ${STAGING_INCDIR}/pcap/pcap.h
+ install -m 0644 pcap/namedb.h ${STAGING_INCDIR}/pcap/namedb.h
+ install -m 0644 pcap/bpf.h ${STAGING_INCDIR}/pcap/bpf.h
+}
+
+