summaryrefslogtreecommitdiff
path: root/recipes/jpeg/jpeg_6b.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/jpeg/jpeg_6b.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/jpeg/jpeg_6b.bb')
-rw-r--r--recipes/jpeg/jpeg_6b.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes/jpeg/jpeg_6b.bb b/recipes/jpeg/jpeg_6b.bb
new file mode 100644
index 0000000000..48771c8de5
--- /dev/null
+++ b/recipes/jpeg/jpeg_6b.bb
@@ -0,0 +1,48 @@
+DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
+LICENSE ="jpeg"
+SECTION = "libs"
+PRIORITY = "required"
+
+DEPENDS = "libtool-cross"
+RPROVIDES_${PN} = "jpeg"
+
+PR = "r8"
+
+SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
+ file://debian.patch;patch=1 \
+ file://ldflags.patch;patch=1 \
+ file://paths.patch;patch=1 \
+ file://libtool_tweak.patch;patch=1"
+S = "${WORKDIR}/jpeg-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF="--enable-static --enable-shared"
+EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"'
+
+CFLAGS_append = " -D_REENTRANT"
+
+do_configure_prepend () {
+ rm -f ${S}/ltconfig
+ rm -f ${S}/ltmain.sh
+}
+
+do_stage() {
+ install -m 644 jconfig.h ${STAGING_INCDIR}/jconfig.h
+ install -m 644 jpeglib.h ${STAGING_INCDIR}/jpeglib.h
+ install -m 644 jmorecfg.h ${STAGING_INCDIR}/jmorecfg.h
+ install -m 644 jerror.h ${STAGING_INCDIR}/jerror.h
+ install -m 644 jpegint.h ${STAGING_INCDIR}/jpegint.h
+ oe_libinstall -so libjpeg ${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir} ${D}${includedir} \
+ ${D}${mandir}/man1 ${D}${libdir}
+ oe_runmake 'DESTDIR=${D}' install
+}
+
+PACKAGES =+ "jpeg-tools "
+FILES_jpeg-tools = "${bindir}/*"
+
+