summaryrefslogtreecommitdiff
path: root/recipes/install/install-native_0.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/install/install-native_0.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/install/install-native_0.1.bb')
-rw-r--r--recipes/install/install-native_0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/install/install-native_0.1.bb b/recipes/install/install-native_0.1.bb
new file mode 100644
index 0000000000..70c027bfe1
--- /dev/null
+++ b/recipes/install/install-native_0.1.bb
@@ -0,0 +1,27 @@
+# This package uses the GNU autotools install-sh script to implement
+# a target-capable 'install' command.
+DESCRIPTION = "Target install command"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
+
+SRC_URI = "file://install-sh"
+
+inherit native
+
+PACKAGES = ""
+S = "${WORKDIR}"
+
+do_stage() {
+ # When the install command is executed 'STRIP' is defined correctly in
+ # the environment
+ rm -f ${STAGING_BINDIR}/install-sh
+ cp install-sh ${STAGING_BINDIR}/install-sh
+ chmod 755 ${STAGING_BINDIR}/install-sh
+ rm -f ${STAGING_BINDIR}/install
+ echo '#!/bin/sh' >${STAGING_BINDIR}/install
+ echo 'STRIPPROG="$STRIP" exec sh "${STAGING_BINDIR}/install-sh" "$@"' >>${STAGING_BINDIR}/install
+ chmod 755 ${STAGING_BINDIR}/install
+}