summaryrefslogtreecommitdiff
path: root/recipes/images/slugos-image.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2009-04-30 16:35:05 -0500
committerMike Westerhof <mwester@dls.net>2009-04-30 16:36:35 -0500
commite40bd5bec56b83aa39b1f5a3a62e17c6d1ddf60f (patch)
tree0780a037341bd1cf945ee5c2b5e976a736e4aa3c /recipes/images/slugos-image.bb
parent87fbf88f7e448eb9381f7fc0551dd386616c6f9b (diff)
SlugOS: refactor slugos images and tasks to support a standard and extended image.
Diffstat (limited to 'recipes/images/slugos-image.bb')
-rw-r--r--recipes/images/slugos-image.bb21
1 files changed, 4 insertions, 17 deletions
diff --git a/recipes/images/slugos-image.bb b/recipes/images/slugos-image.bb
index 24ba91552f..24e83f0b66 100644
--- a/recipes/images/slugos-image.bb
+++ b/recipes/images/slugos-image.bb
@@ -2,24 +2,11 @@
# called 'slugos-image.bb' the distro specific configuration is
# done in conf/distro/${DISTRO}.conf (which should always include
# conf/distro/slugos.conf to get the standard settings).
-#
-DESCRIPTION = "Generic SlugOS image"
-HOMEPAGE = "http://www.nslu2-linux.org"
-
-DEPENDS = "task-slugos"
-IMAGE_INSTALL = "task-slugos"
-COMPATIBLE_MACHINE = "nslu2|ixp4xx"
+DESCRIPTION = "Generic SlugOS image"
-IMAGE_NAME = "${IMAGE_BASENAME}-${DISTRO_VERSION}"
-IMAGE_FSTYPES = "jffs2 tar.gz"
-IMAGE_DEVICE_TABLES = "files/device_table-slugos.txt"
-IMAGE_LINGUAS = ""
+PR = "r1"
-# IMAGE_PREPROCESS_COMMAND is run before making the image. In SlugOS the
-# kernel image is removed from the root file system to recover the space used -
-# SlugOS is assumed to boot from a separate kernel image in flash (not in the
-# root file system), if this is not the case the following must not be done!
-IMAGE_PREPROCESS_COMMAND += "rm ${IMAGE_ROOTFS}/boot/zImage*;"
+require slugos-image.inc
-inherit image nslu2-image
+inherit nslu2-image