summaryrefslogtreecommitdiff
path: root/recipes/images/liveramdisk-image.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/images/liveramdisk-image.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/images/liveramdisk-image.bb')
-rw-r--r--recipes/images/liveramdisk-image.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/images/liveramdisk-image.bb b/recipes/images/liveramdisk-image.bb
new file mode 100644
index 0000000000..5caa4baa11
--- /dev/null
+++ b/recipes/images/liveramdisk-image.bb
@@ -0,0 +1,22 @@
+# LiveRamdisk image
+# Building with ANGSTROMLIBC=uclibc is recommended
+#
+# LiveRamdisk concept/implementation by Paul Sokolovsky
+LICENSE = "MIT"
+IMAGE_FSTYPES = "cpio.gz"
+
+#IMAGE_INSTALL = "initramfs-boot busybox kernel-module-uinput uclibc libgcc1"
+IMAGE_INSTALL = "initramfs-jffs2 busybox-static kernel-module-mtdram"
+
+export IMAGE_BASENAME = "liveramdisk"
+export IMAGE_LINGUAS = ""
+
+# Install only ${IMAGE_INSTALL}, not even deps
+#PACKAGE_INSTALL_NO_DEPS = "1"
+
+# Remove any kernel-image that the kernel-module-* packages may have pulled in.
+PACKAGE_REMOVE = "kernel-image-* update-modules module-init-tools-depmod uclibc update-rc.d"
+ROOTFS_POSTPROCESS_COMMAND += "opkg-cl ${IPKG_ARGS} -force-depends \
+ remove ${PACKAGE_REMOVE};"
+
+inherit image