summaryrefslogtreecommitdiff
path: root/recipes/i2c-tools/picodlp-control_0.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/i2c-tools/picodlp-control_0.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/i2c-tools/picodlp-control_0.1.bb')
-rw-r--r--recipes/i2c-tools/picodlp-control_0.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/i2c-tools/picodlp-control_0.1.bb b/recipes/i2c-tools/picodlp-control_0.1.bb
new file mode 100644
index 0000000000..5fb5630d87
--- /dev/null
+++ b/recipes/i2c-tools/picodlp-control_0.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Small application to control the pico DLP over I2C"
+LICENSE = "GPLv3"
+PR = "r3"
+
+SRC_URI = "file://*.c file://*.h file://${PN}"
+
+do_configure() {
+ cp ${WORKDIR}/*.[ch] ${WORKDIR}/${PN} ${S}
+}
+
+do_compile() {
+ ${CC} -o bus3-i2c *.c ${CFLAGS} ${LDFLAGS}
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/${PN} ${D}/${bindir}
+ install -m 0755 ${S}/bus3-i2c ${D}/${bindir}
+}
+