summaryrefslogtreecommitdiff
path: root/recipes/hotplug-ng/hotplug-ng_002.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/hotplug-ng/hotplug-ng_002.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/hotplug-ng/hotplug-ng_002.bb')
-rw-r--r--recipes/hotplug-ng/hotplug-ng_002.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/hotplug-ng/hotplug-ng_002.bb b/recipes/hotplug-ng/hotplug-ng_002.bb
new file mode 100644
index 0000000000..3c5014be9a
--- /dev/null
+++ b/recipes/hotplug-ng/hotplug-ng_002.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
+package with very tiny, compiled executable programs, instead of the \
+existing bash scripts."
+LICENSE = "GPL"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz"
+
+#S = "${WORKDIR}/hotplug-ng-${PV}"
+
+LD = "${CC}"
+export HOSTCC = "${BUILD_CC}"
+CFLAGS = " -I${S}/libsysfs/sysfs"
+# Stripping should be done when _packaging_, not building
+EXTRA_OEMAKE += "'STRIP=/bin/true'"
+
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export bindir = "${base_bindir}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}