summaryrefslogtreecommitdiff
path: root/recipes/hostap/hostap-utils_0.4.7.bb
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-04-17 16:24:46 -0400
committerTom Rini <trini@embeddedalley.com>2009-04-17 16:24:46 -0400
commitc8b3cc5ef81d305d5d90644da36acbc40c7c01f1 (patch)
treec5780e1ec137dd4cf71d54ba07e41d7795148b75 /recipes/hostap/hostap-utils_0.4.7.bb
parent49a720ff8597243a906d7c0f9278ca8f1f9ff670 (diff)
parenta4f79016c537fc93e5a487d51a22fb4d01e9afe8 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/hostap/hostap-utils_0.4.7.bb')
-rw-r--r--recipes/hostap/hostap-utils_0.4.7.bb24
1 files changed, 23 insertions, 1 deletions
diff --git a/recipes/hostap/hostap-utils_0.4.7.bb b/recipes/hostap/hostap-utils_0.4.7.bb
index 9fe362b19f..563594780d 100644
--- a/recipes/hostap/hostap-utils_0.4.7.bb
+++ b/recipes/hostap/hostap-utils_0.4.7.bb
@@ -1 +1,23 @@
-require hostap-utils.inc
+DESCRIPTION = "User mode helpers for the hostap driver"
+HOMEPAGE = "http://hostap.epitest.fi"
+SECTION = "kernel/userland"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "r6"
+
+SRC_URI = "http://hostap.epitest.fi/releases/hostap-utils-${PV}.tar.gz \
+ file://hostap-fw-load.patch;patch=1 \
+ file://ldflags.patch;patch=1"
+
+S = "${WORKDIR}/hostap-utils-${PV}"
+
+BINARIES = "hostap_crypt_conf hostap_diag hostap_fw_load hostap_io_debug \
+ hostap_rid prism2_param prism2_srec split_combined_hex"
+
+do_install() {
+ install -d ${D}${sbindir}/
+ for f in ${BINARIES}
+ do
+ install -m 0755 $f ${D}${sbindir}/
+ done
+}