summaryrefslogtreecommitdiff
path: root/recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb')
-rw-r--r--recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb b/recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb
new file mode 100644
index 0000000000..43037573f4
--- /dev/null
+++ b/recipes/hfsplusutils/hfsplusutils_1.0.4-4.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "HFS plus file system utilities"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r1"
+
+S="${WORKDIR}/${P}"
+
+inherit kernel-arch autotools pkgconfig
+
+DEPENDS = " rpm2cpio-native"
+
+SRC_URI = "http://penguinppc.org/historical/hfsplus/hfsplusutils-1.0.4-4.src.rpm \
+ file://hfsplusutils-1.0.4-errno.patch;patch=1 \
+ file://hfsplusutils-1.0.4-gcc4.patch;patch=1 \
+ file://hfsplusutils-1.0.4-glob.patch;patch=1 \
+ file://hfsplusutils-1.0.4-string.patch;patch=1 \
+ "
+
+do_unpack() {
+ if ! test -f hfsplus.tz2 ; then
+ rpm2cpio.pl ${DL_DIR}/${P}.src.rpm | cpio -i --make-directories
+ bunzip2 hfsplus.tz2
+ tar -xf hfsplus.tz2.out
+ mv hfsplus ${P}
+ fi
+}