summaryrefslogtreecommitdiff
path: root/recipes/helloworld/helloworld_1.0.0.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-12-10 11:08:51 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2009-12-10 11:08:51 +0100
commita79d5a546392cad57bb8855f88d4617caa852d27 (patch)
tree28a5b26bf27ff1e594e13e6eb5aa76891f8f8aab /recipes/helloworld/helloworld_1.0.0.bb
parent09a85ada712374f567b276067805c19b091a518a (diff)
parent6e0172f360053c39bfad106592fbb55509167103 (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/helloworld/helloworld_1.0.0.bb')
-rw-r--r--recipes/helloworld/helloworld_1.0.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/recipes/helloworld/helloworld_1.0.0.bb b/recipes/helloworld/helloworld_1.0.0.bb
index af29a7769a..83b3965960 100644
--- a/recipes/helloworld/helloworld_1.0.0.bb
+++ b/recipes/helloworld/helloworld_1.0.0.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "Minimal statically compiled Hello world!"
LICENSE = "GPL"
-PR = "r0"
+PR = "r1"
S = "${WORKDIR}/${P}"
@@ -11,7 +11,8 @@ do_fetch () {
}
do_compile () {
- ${CC} -o helloworld helloworld.c -static
+ ${CC} ${CFLAGS} -c -o helloworld.o helloworld.c
+ ${CC} ${LDFLAGS} -o helloworld helloworld.o -static
}
do_install () {