summaryrefslogtreecommitdiff
path: root/recipes/hal/hal_0.5.12.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-05-18 14:23:59 +0200
committerKoen Kooi <koen@openembedded.org>2009-05-18 14:23:59 +0200
commit4e3165e4bbb28bc765397588c69f67f7f37338d3 (patch)
treee3097d1d572acfb713c5af17b9442106af8d440e /recipes/hal/hal_0.5.12.bb
parent3d1136959ad0b77bdb37a418f17925bd5b8bcd05 (diff)
hal: add (disabled) hal 0.5.12
Diffstat (limited to 'recipes/hal/hal_0.5.12.bb')
-rw-r--r--recipes/hal/hal_0.5.12.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/recipes/hal/hal_0.5.12.bb b/recipes/hal/hal_0.5.12.bb
new file mode 100644
index 0000000000..b6531e8235
--- /dev/null
+++ b/recipes/hal/hal_0.5.12.bb
@@ -0,0 +1,11 @@
+require hal.inc
+
+DEFAULT_PREFERENCE = "-1"
+
+# The following code finds the right linux/input.h,
+# which also works with external-toolchain/SDK
+do_configure() {
+ linux_input_h=`echo "#include <linux/input.h>" | ${CPP} - | \
+ grep "linux\/input.h" | head -n 1 | awk -F '"' '{print $2}'`
+ autotools_do_configure --with-linux-input-header=${linux_input_h}
+}