summaryrefslogtreecommitdiff
path: root/recipes/gs/gs_8.16.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/gs/gs_8.16.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/gs/gs_8.16.bb')
-rw-r--r--recipes/gs/gs_8.16.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gs/gs_8.16.bb b/recipes/gs/gs_8.16.bb
new file mode 100644
index 0000000000..cf1e8ba411
--- /dev/null
+++ b/recipes/gs/gs_8.16.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "An interpreter of the Postscript language"
+LICENSE = "GPL"
+SECTION = "console/utils"
+HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
+DEPENDS = "jpeg zlib"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/ghostscript/gnu-ghostscript-${PV}.tar.gz"
+S = "${WORKDIR}/gnu-ghostscript-${PV}"
+
+inherit autotools flow-lossage
+
+EXTRA_OECONF = "--without-x"
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_compile() {
+ oe_runmake CCAUX="${BUILD_CC}"
+}
+
+do_install() {
+ oe_runmake bindir='${D}${bindir}' datadir='${D}${datadir}' libdir='${D}${libdir}' install
+}
+
+FILES_${PN} += "${datadir}/ghostscript"