summaryrefslogtreecommitdiff
path: root/recipes/grep/grep_2.6.3.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-02 12:51:36 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-05 06:52:40 -0700
commit387fc78ae86677b01052733b819860597f1fc6fb (patch)
treee8ca412df42918a29c712733dc65cef986108ca7 /recipes/grep/grep_2.6.3.bb
parentc9f7d8d8f62e3c4b2e30332401f2c177a1436ad0 (diff)
grep-2.6.3: Add recipe.
* Fix build for uclibc as well. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/grep/grep_2.6.3.bb')
-rw-r--r--recipes/grep/grep_2.6.3.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes/grep/grep_2.6.3.bb b/recipes/grep/grep_2.6.3.bb
new file mode 100644
index 0000000000..c887ca007d
--- /dev/null
+++ b/recipes/grep/grep_2.6.3.bb
@@ -0,0 +1,47 @@
+LICENSE = "GPL"
+SECTION = "console/utils"
+DESCRIPTION = "grep GNU utility"
+PR = "r0"
+
+SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.xz \
+ file://uclibc-fix.patch"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
+EXTRA_OECONF_virtclass-native = "--with-included-regex --disable-ncurses"
+
+do_configure () {
+ rm -f ${S}/m4/init.m4
+ autotools_do_configure
+}
+
+do_install () {
+ autotools_do_install
+ install -d ${D}${base_bindir}
+ mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
+ mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
+ mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
+}
+
+do_install_virtclass-native () {
+ autotools_do_install
+}
+
+pkg_postinst_${PN} () {
+ update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
+ update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
+ update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
+}
+
+pkg_prerm_${PN} () {
+ update-alternatives --remove grep grep.${PN}
+ update-alternatives --remove egrep egrep.${PN}
+ update-alternatives --remove fgrep fgrep.${PN}
+}
+
+BBCLASSEXTEND = "native"
+
+SRC_URI[md5sum] = "69a3bf508a3f14d12369e0e1c7a92763"
+SRC_URI[sha256sum] = "ba745e2ff297ab225bf870740d35593d402a1d92999cf0d7e56840f10218db7c"
+