summaryrefslogtreecommitdiff
path: root/recipes/gpe-icons/gpe-theme-neo_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-07 13:08:25 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-07 13:11:38 +0100
commit2df4f2cfe72f40fb92c696674f2b3118ae386fab (patch)
treeddd95a4b1c5e61130b004a39a1a2e582412106f3 /recipes/gpe-icons/gpe-theme-neo_git.bb
parentcc1c330520dc780748eff80c89fa2e02616d5f6b (diff)
gpe-theme-neo: add recipe from shr/merge
* gpe-icons.inc: for switching gpe icon theme with u-a and merging installed alternatives of together * standard gpe-icons recipe with require gpe-icons.inc will follow later. I need to prepare some switch for distro to choose if u-a should be used for gpe-icons.
Diffstat (limited to 'recipes/gpe-icons/gpe-theme-neo_git.bb')
-rw-r--r--recipes/gpe-icons/gpe-theme-neo_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gpe-icons/gpe-theme-neo_git.bb b/recipes/gpe-icons/gpe-theme-neo_git.bb
new file mode 100644
index 0000000000..192c8a7d8e
--- /dev/null
+++ b/recipes/gpe-icons/gpe-theme-neo_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "nEo GPE theme - a very fast, high contrast GPE theme"
+SECTION = "gpe"
+HOMEPAGE = "http://jmccloud.jm.funpic.de"
+AUTHOR = "Jesus McCloud <bernd.pruenster@gmail.com"
+RDEPENDS = "gdk-pixbuf-loader-png gpe-filemanager gpe-sketchbook"
+RRECOMMENDS = "elementary-theme-neo e-wm-theme-illume-neo gtk-theme-neo libframeworkd-phonegui-efl-theme-neo etk-theme-neo icon-theme-neo"
+LICENSE = "unknown"
+
+PV = "0.2-${EFL_SRCREV}+gitr${SRCPV}"
+PR = "${INC_PR}.0"
+
+SRC_URI = "git://git.shr-project.org/repo/shr-themes.git;protocol=http;branch=master"
+
+S = "${WORKDIR}/git/gpe/theme-neo/pixmaps"
+
+require gpe-icons.inc
+
+do_install() {
+ install -d ${D}${datadir}/gpe/
+ install -d ${D}${datadir}/gpe/pixmaps.${PN}/
+ cp -r ${S}/* "${D}${datadir}/gpe/pixmaps.${PN}/"
+}
+
+FILES_${PN} = "${datadir}/gpe/pixmaps.${PN}/"
+