summaryrefslogtreecommitdiff
path: root/recipes/gnome/libgweather_2.26.2.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-14 11:52:15 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-14 11:52:15 -0700
commitdc0604b297a6d3bf66baff8cd657ad0b677b1bea (patch)
tree70542b8de6aee550c0682bc4e21c715b19ce6f97 /recipes/gnome/libgweather_2.26.2.1.bb
parent786619e5a2cb4058f1e6bebb401f1bb8af7efe12 (diff)
parent3e633b49e2c54124cf8b2ecdbb2ed3d98d307ef9 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/gnome/libgweather_2.26.2.1.bb')
-rw-r--r--recipes/gnome/libgweather_2.26.2.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/gnome/libgweather_2.26.2.1.bb b/recipes/gnome/libgweather_2.26.2.1.bb
new file mode 100644
index 0000000000..e97bff1aee
--- /dev/null
+++ b/recipes/gnome/libgweather_2.26.2.1.bb
@@ -0,0 +1,28 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome libsoup-2.4 gtk+"
+
+PR = "r1"
+
+inherit gnome
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_configure_prepend() {
+ sed -i -e 's:help::' ${S}/Makefile.am
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/gnome* \
+ ${datadir}/icons"
+
+PACKAGES =+ "${PN}-locationdata"
+FILES_${PN}-locationdata = "${datadir}/libgweather/Locations*"
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+