summaryrefslogtreecommitdiff
path: root/recipes/gettext/gettext_0.18.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2010-06-02 12:45:28 -0700
committerKhem Raj <raj.khem@gmail.com>2010-06-05 06:52:39 -0700
commit9991720b9967ee803bea600a355410878569c843 (patch)
tree39f9f9d8a56c2332605d98a52c300789b92c5598 /recipes/gettext/gettext_0.18.bb
parent61f0980015f29d6050d6d44b8029b757978b51d6 (diff)
gettext-0.18: Add recipe for 0.18
* gl_cv_func_unsetenv_works is not computed correctly in cross environment so cache it. Signed-off-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/gettext/gettext_0.18.bb')
-rw-r--r--recipes/gettext/gettext_0.18.bb57
1 files changed, 57 insertions, 0 deletions
diff --git a/recipes/gettext/gettext_0.18.bb b/recipes/gettext/gettext_0.18.bb
new file mode 100644
index 0000000000..5e22b5a5b6
--- /dev/null
+++ b/recipes/gettext/gettext_0.18.bb
@@ -0,0 +1,57 @@
+DESCRIPTION = "The GNU internationalization library."
+HOMEPAGE = "http://www.gnu.org/software/gettext/gettext.html"
+SECTION = "libs"
+LICENSE = "GPLv3"
+PR = "r0"
+DEPENDS = "gettext-native virtual/libiconv ncurses expat"
+DEPENDS_virtclass-native = "libxml2-native"
+PROVIDES = "virtual/libintl"
+PROVIDES_virtclass-native = ""
+RCONFLICTS_gettext-libintl = "proxy-libintl"
+
+BBCLASSEXTEND = "native nativesdk"
+
+SRC_URI = "${GNU_MIRROR}/gettext/gettext-${PV}.tar.gz \
+ file://autotools.patch \
+ file://gettext-autoconf-lib-link-no-L.patch \
+ file://gnulib-uclibc-sched_param-def.patch \
+ "
+
+SRC_URI_append_libc-uclibc = " file://gettext-error_print_progname.patch"
+
+PARALLEL_MAKE = ""
+
+inherit autotools
+
+EXTRA_OECONF += "--without-lispdir \
+ --disable-csharp \
+ --disable-libasprintf \
+ --disable-java \
+ --disable-native-java \
+ --disable-openmp \
+ --with-included-glib \
+ --without-emacs \
+ "
+acpaths = '-I ${S}/gnulib-local/m4/ \
+ -I ${S}/gettext-runtime/m4 \
+ -I ${S}/gettext-tools/m4'
+
+
+# these lack the .x behind the .so, but shouldn't be in the -dev package
+# Otherwise you get the following results:
+# 7.4M glibc/images/ep93xx/Angstrom-console-image-glibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
+# 25M uclibc/images/ep93xx/Angstrom-console-image-uclibc-ipk-2008.1-test-20080104-ep93xx.rootfs.tar.gz
+# because gettext depends on gettext-dev, which pulls in more -dev packages:
+# 15228 KiB /ep93xx/libstdc++-dev_4.2.2-r2_ep93xx.ipk
+# 1300 KiB /ep93xx/uclibc-dev_0.9.29-r8_ep93xx.ipk
+# 140 KiB /armv4t/gettext-dev_0.14.1-r6_armv4t.ipk
+# 4 KiB /ep93xx/libgcc-s-dev_4.2.2-r2_ep93xx.ipk
+
+PACKAGES =+ "gettext-libintl libgettextlib libgettextsrc"
+
+FILES_gettext-libintl = "${libdir}/libintl*.so.*"
+FILES_libgettextlib = "${libdir}/libgettextlib-*.so*"
+FILES_libgettextsrc = "${libdir}/libgettextsrc-*.so*"
+
+SRC_URI[md5sum] = "d52a3e061032a1ed13856d42fc86f0fd"
+SRC_URI[sha256sum] = "02342c1de18c03c601f8b91cbd896b70486a4b945bd816f34541e0d7b5a96fe5"