summaryrefslogtreecommitdiff
path: root/recipes/gettext/gettext-native_0.14.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/gettext/gettext-native_0.14.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/gettext/gettext-native_0.14.1.bb')
-rw-r--r--recipes/gettext/gettext-native_0.14.1.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes/gettext/gettext-native_0.14.1.bb b/recipes/gettext/gettext-native_0.14.1.bb
new file mode 100644
index 0000000000..f792f3247a
--- /dev/null
+++ b/recipes/gettext/gettext-native_0.14.1.bb
@@ -0,0 +1,60 @@
+require gettext_${PV}.bb
+S = "${WORKDIR}/gettext-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gettext-${PV}"
+inherit native
+DEPENDS = ""
+PROVIDES = ""
+
+M4 = "\
+lib-ld.m4 \
+lib-link.m4 \
+lib-prefix.m4 \
+codeset.m4 \
+gettext.m4 \
+glibc21.m4 \
+iconv.m4 \
+intdiv0.m4 \
+intmax.m4 \
+inttypes.m4 \
+inttypes_h.m4 \
+inttypes-pri.m4 \
+isc-posix.m4 \
+lcmessage.m4 \
+longdouble.m4 \
+longlong.m4 \
+nls.m4 \
+po.m4 \
+printf-posix.m4 \
+progtest.m4 \
+signed.m4 \
+size_max.m4 \
+stdint_h.m4 \
+uintmax_t.m4 \
+ulonglong.m4 \
+wchar_t.m4 \
+wint_t.m4 \
+xsize.m4 \
+"
+
+do_stage_append() {
+ for i in ${M4}; do
+ src="gettext-runtime/m4/$i"
+ if [ ! -f $src ]; then
+ src="gettext-tools/m4/$i"
+ fi
+ if [ ! -f $src ]; then
+ src="autoconf-lib-link/m4/$i"
+ fi
+ if [ ! -f $src ]; then
+ echo "can't find $i" >&2
+ exit 1
+ fi
+ install -m 0644 $src ${STAGING_DATADIR}/aclocal/$i
+ done
+ # config.rpath is needed by some configure macros and needs to be autoinstalled.
+ # automake will do this but config.rpath needs to be visible to automake
+ for i in `ls -d ${STAGING_DATADIR}/automake*`
+ do
+ cp ${STAGING_DATADIR}/gettext/config.rpath $i
+ done
+}