summaryrefslogtreecommitdiff
path: root/recipes/gdb/gdb-7.1
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-06-12 22:21:07 +0200
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2010-06-12 22:21:07 +0200
commitc326ad5a1960df22c5efd71bd815b9b12688556e (patch)
tree09bd868c4446f3510a070ed601e7b67c6b791cde /recipes/gdb/gdb-7.1
parentdd0fdfe9ed922189f4251c688b7a16faa76cd904 (diff)
parent2bca6bd1a15123af28ff5ef8fd6ebb417a3a4dee (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Conflicts: recipes/tgt/tgt_1.0.5.bb
Diffstat (limited to 'recipes/gdb/gdb-7.1')
-rw-r--r--recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch b/recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch
new file mode 100644
index 0000000000..d642721127
--- /dev/null
+++ b/recipes/gdb/gdb-7.1/gdb-tcsetpgrp.patch
@@ -0,0 +1,43 @@
+Stuart Hughes, stuarth@freescale.com 8th April 05
+
+Extracted from:
+
+From: Davin Milun (milun@cs.buffalo.edu)
+Subject: Re: xxgdb for Solaris
+View: Complete Thread (4 articles)
+Original Format
+Newsgroups: comp.unix.solaris
+Date: 1995/05/05
+
+Geraldo Veiga <ggv@research.att.com> wrote:
+>Now, how do I avoid those
+>
+>[tcsetpgrp failed in terminal_inferior: Inappropriate ioctl for device]
+>
+>messages at every step the program takes under mxgdb (and xxgdb)?. I am
+>running GDB4.13 under Solaris 2.4.
+
+You need to patch inflow.c.
+
+
+ diff --exclude CVS -uNr gdb-6.0/gdb/inflow.c gdb-6.0.modified/gdb/inflow.c
+Index: gdb-7.1/gdb/inflow.c
+===================================================================
+--- gdb-7.1.orig/gdb/inflow.c 2010-01-21 06:26:12.000000000 -0800
++++ gdb-7.1/gdb/inflow.c 2010-06-09 13:59:33.761358724 -0700
+@@ -308,13 +308,13 @@ terminal_inferior (void)
+ {
+ #ifdef HAVE_TERMIOS
+ result = tcsetpgrp (0, tinfo->process_group);
+- if (!inf->attach_flag)
++ if (!inf->attach_flag && errno != ENOTTY)
+ OOPSY ("tcsetpgrp");
+ #endif
+
+ #ifdef HAVE_SGTTY
+ result = ioctl (0, TIOCSPGRP, &tinfo->process_group);
+- if (!inf->attach_flag)
++ if (!inf->attach_flag && errno != ENOTTY)
+ OOPSY ("TIOCSPGRP");
+ #endif
+ }