summaryrefslogtreecommitdiff
path: root/recipes/freesmartphone/pycd_git.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-08-06 23:51:34 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-08-07 02:49:56 +0200
commit8aaba52bea14032340a37959af4a57047cb03c1b (patch)
treea8e45a14240e95aa7058c8f88476448f831a274f /recipes/freesmartphone/pycd_git.bb
parentc579f58d519f6e2e58a3b5acc52fc3d9cd953c3d (diff)
freesmartphone: catch up with milestone5.5 and SHR/import
Diffstat (limited to 'recipes/freesmartphone/pycd_git.bb')
-rw-r--r--recipes/freesmartphone/pycd_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/freesmartphone/pycd_git.bb b/recipes/freesmartphone/pycd_git.bb
new file mode 100644
index 0000000000..3ed2b75292
--- /dev/null
+++ b/recipes/freesmartphone/pycd_git.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Python Clone Factory"
+AUTHOR = "Jan Luebbe <jluebbe@debian.org>"
+HOMEPAGE = "http://www.freesmartphone.org"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+PV = "0.1+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/python-helpers.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/${PN}"
+
+RDEPENDS_${PN} = "\
+ python-dbus \
+ python-misc \
+ python-pkgutil \
+ python-resource \
+"
+
+do_compile() {
+ ${CC} pyc.c -o pyc
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 pyc ${D}${bindir}/pyc
+ install -d ${D}${sbindir}
+ install -m 755 pycd.py ${D}${sbindir}/pycd
+ install -d ${D}${sysconfdir}/dbus-1
+ install -m 644 pycd.conf ${D}${sysconfdir}/dbus-1
+}
+