summaryrefslogtreecommitdiff
path: root/recipes/freesmartphone/fsodeviced_git.bb
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-24 16:33:51 +0000
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-11-24 16:33:51 +0000
commit9a681a2affece3d2a9230c4939450d9392c33bf9 (patch)
tree15f0a38d8bdee1eb0e9bae2e6277b03c28bd3fe8 /recipes/freesmartphone/fsodeviced_git.bb
parent880e00d3b7ccf66d9421a06bc28e553e07842b59 (diff)
parenta12117346588829898e6a041a4432fb0370c0c76 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded
Diffstat (limited to 'recipes/freesmartphone/fsodeviced_git.bb')
-rw-r--r--recipes/freesmartphone/fsodeviced_git.bb17
1 files changed, 16 insertions, 1 deletions
diff --git a/recipes/freesmartphone/fsodeviced_git.bb b/recipes/freesmartphone/fsodeviced_git.bb
index 1b01241e4c..0fe723ff32 100644
--- a/recipes/freesmartphone/fsodeviced_git.bb
+++ b/recipes/freesmartphone/fsodeviced_git.bb
@@ -5,4 +5,19 @@ DEPENDS += "alsa-lib libcanberra libfsoresource"
RDEPENDS += "libcanberra-alsa"
RRECOMMENDS += "fso-alsa-data"
PV = "0.9.0+gitr${SRCREV}"
-PR = "${INC_PR}.0"
+PE = "1"
+PR = "${INC_PR}.3"
+
+inherit update-rc.d
+
+INITSCRIPT_NAME = "fsodeviced"
+INITSCRIPT_PARAMS = "defaults 27"
+
+SRC_URI += "file://fsodeviced"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fsodeviced ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${sysconfdir}/init.d/fsodeviced"