summaryrefslogtreecommitdiff
path: root/recipes/freesmartphone/fso-gpsd_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/freesmartphone/fso-gpsd_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/freesmartphone/fso-gpsd_git.bb')
-rw-r--r--recipes/freesmartphone/fso-gpsd_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/freesmartphone/fso-gpsd_git.bb b/recipes/freesmartphone/fso-gpsd_git.bb
new file mode 100644
index 0000000000..cde1bb65e3
--- /dev/null
+++ b/recipes/freesmartphone/fso-gpsd_git.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "freesmartphone.org gpsd compatibility daemon"
+LICENSE = "GPL"
+SECTION = "network"
+DEPENDS = "dbus-glib"
+PV = "0.8+gitr${SRCREV}"
+PR = "r2"
+
+SRC_URI = "\
+ ${FREESMARTPHONE_GIT}/fso-gpsd.git;protocol=git;branch=master \
+ file://fso-gpsd \
+"
+S = "${WORKDIR}/git"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "fso-gpsd"
+INITSCRIPT_PARAMS = "defaults 35"
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/fso-gpsd ${D}${sysconfdir}/init.d/
+}
+
+FILES_${PN} += "${sysconfdir}"
+RDEPENDS_${PN} = "frameworkd"
+RPROVIDES_${PN} = "gpsd"
+# Disabled as we always got gpsd but not fso-gpsd in the fso-image. Needs
+# fixing.
+#RCONFLICTS_${PN} = "gpsd"